# Insufficient type validation in pocketmine/pocketmine-mp

Advisory record · `GHSA-g5rr-p69h-7v3g`

- **Identifiers:** `GHSA-g5rr-p69h-7v3g` · `CVE-2022-51012` · `PKSA-8sgq-z2gv-62hz`
- **State:** Confirmed
- **Severity:** CVSS 7.1 High
- **Critical:** No
- **Weakness (CWE):** [CWE-20](https://cwe.mitre.org/data/definitions/20.html) · [CWE-1287](https://cwe.mitre.org/data/definitions/1287.html)
- **Tags:** [CWE-20](https://agentprime.io/advisories/tag/cwe-20.md) · [CWE-1287](https://agentprime.io/advisories/tag/cwe-1287.md)
- **Published:** 22 Apr 2022
- **Updated:** 8 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 22 Apr 2022, 20:57 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `pocketmine/pocketmine-mp` (Packagist): affected `<4.2.9`; fixed in `4.2.9`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The pocketmine/pocketmine-mp package for PHP is vulnerable in versions before 4.2.9. When a player performs an inventory action, the server deserializes item NBT sent by the client, and malformed data such as an incorrect list tag type for a block-related tag can crash the server. The source does not state what access an attacker needs beyond connecting as a client. Upgrade to version 4.2.9, which includes the fix; the workaround described in the source is non-trivial.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.1 High, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`, from CNA (VulnCheck)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0053, the 44th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:06 UTC: First seen by agentprime
- 31 Oct 2026, 14:06 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-g5rr-p69h-7v3g)

## Sources

- [GitHub Advisory Database: GHSA-g5rr-p69h-7v3g](https://github.com/advisories/GHSA-g5rr-p69h-7v3g)
- [OSV: GHSA-g5rr-p69h-7v3g](https://osv.dev/vulnerability/GHSA-g5rr-p69h-7v3g)
- <https://github.com/pmmp/PocketMine-MP/security/advisories/GHSA-g5rr-p69h-7v3g>
- <https://github.com/pmmp/PocketMine-MP/commit/5a98b08ee8dc8ff14862cd83d2e4af9d212fefc2>
- <https://github.com/pmmp/PocketMine-MP>
- <https://github.com/pmmp/PocketMine-MP/blob/4.2.9/changelogs/4.2.md#429>
- <https://github.com/pmmp/PocketMine-MP/releases/tag/4.2.9>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-g5rr-p69h-7v3g>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-g5rr-p69h-7v3g/>. Everything for agents: <https://agentprime.io/llms.txt>.
