# Apache Airflow has DAG Author Code Execution possibility in airflow-scheduler

Advisory record · `GHSA-g5hv-r743-v8pm`

- **Identifiers:** `GHSA-g5hv-r743-v8pm` · `BIT-airflow-2024-39877` · `CVE-2024-39877` · `PYSEC-2024-190`
- **State:** Confirmed
- **Severity:** CVSS 8.8 High
- **Critical:** No
- **Weakness (CWE):** [CWE-94](https://cwe.mitre.org/data/definitions/94.html) · [CWE-277](https://cwe.mitre.org/data/definitions/277.html)
- **Tags:** [Code injection](https://agentprime.io/advisories/tag/code-injection.md) · [CWE-277](https://agentprime.io/advisories/tag/cwe-277.md)
- **Published:** 17 Jul 2024
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 17 Jul 2024, 09:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `apache-airflow` (PyPI): affected `>=2.4.0, <2.9.3`; fixed in `2.9.3`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Apache Airflow versions 2.4.0 up to but not including 2.9.3 are affected. An authenticated DAG author can craft the doc_md parameter so that arbitrary code runs in the scheduler context, which the Airflow security model forbids. Upgrade to Airflow 2.9.3 or later, which removes the vulnerability.

Written 5 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.8 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.017, the 77th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 17 Jul 2024, 07:54 UTC: [Confirmed by the CVE List](https://www.cve.org/CVERecord?id=CVE-2024-39877)
- 17 Jul 2024, 08:15 UTC: [Confirmed by NVD](https://nvd.nist.gov/vuln/detail/CVE-2024-39877)
- 31 Oct 2026, 14:35 UTC: First seen by agentprime
- 31 Oct 2026, 14:35 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-g5hv-r743-v8pm)

## Sources

- [GitHub Advisory Database: GHSA-g5hv-r743-v8pm](https://github.com/advisories/GHSA-g5hv-r743-v8pm)
- [OSV: GHSA-g5hv-r743-v8pm](https://osv.dev/vulnerability/GHSA-g5hv-r743-v8pm)
- <https://nvd.nist.gov/vuln/detail/CVE-2024-39877>
- <https://github.com/apache/airflow/pull/40522>
- <https://github.com/apache/airflow/commit/8159f6e24704f5e0e3b3217cf79ecf5083dce531>
- <https://github.com/apache/airflow>
- <https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2024-190.yaml>
- <https://lists.apache.org/thread/1xhj9dkp37d6pzn24ll2mf94wbqnb2y1>
- <http://www.openwall.com/lists/oss-security/2024/07/16/7>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-g5hv-r743-v8pm>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-g5hv-r743-v8pm/>. Everything for agents: <https://agentprime.io/llms.txt>.
