# Nodemailer: Quoted local-part can produce malformed envelope recipient through RFC 5322 comment parsing

Advisory record · `GHSA-g57g-f23g-4646`

- **Identifiers:** `GHSA-g57g-f23g-4646` · `CVE-2026-100699`
- **State:** Confirmed
- **Severity:** CVSS 6.9 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-20](https://cwe.mitre.org/data/definitions/20.html) · [CWE-436](https://cwe.mitre.org/data/definitions/436.html)
- **Tags:** [CWE-20](https://agentprime.io/advisories/tag/cwe-20.md) · [CWE-436](https://agentprime.io/advisories/tag/cwe-436.md)
- **Published:** 29 Sept 2026
- **Updated:** 30 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 29 Sept 2026, 23:44 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `nodemailer` (npm): affected `>=9.1.0, <10.0.9`; fixed in `10.0.9`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Nodemailer versions 9.1.0 before 10.0.9 mis-parse addresses with a quoted local part followed by an RFC 5322 comment, keeping extra domain-like text that is passed into the SMTP envelope recipient. An attacker who controls the comment content could get a malformed recipient used, though the reporter did not confirm delivery to an unintended party. Upgrade to 10.0.9, the fixed version.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.9 Medium, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`, from CNA (VulnCheck)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0023, the 14th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 13:34 UTC: First seen by agentprime
- 31 Oct 2026, 13:34 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-g57g-f23g-4646)

## Sources

- [GitHub Advisory Database: GHSA-g57g-f23g-4646](https://github.com/advisories/GHSA-g57g-f23g-4646)
- [OSV: GHSA-g57g-f23g-4646](https://osv.dev/vulnerability/GHSA-g57g-f23g-4646)
- <https://github.com/nodemailer/nodemailer/security/advisories/GHSA-g57g-f23g-4646>
- <https://github.com/nodemailer/nodemailer/commit/2f36eb1aa1dd33e312411dc9b888548e14db54ee>
- <https://github.com/nodemailer/nodemailer>
- <https://github.com/nodemailer/nodemailer/releases/tag/v10.0.9>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-g57g-f23g-4646>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-g57g-f23g-4646/>. Everything for agents: <https://agentprime.io/llms.txt>.
