# Ansible vulnerable to Exposure of Resource to Wrong Sphere and Insecure Temporary File

Advisory record · `GHSA-g4mq-6fp5-qwcf`

- **Identifiers:** `GHSA-g4mq-6fp5-qwcf` · `CVE-2020-1733` · `PYSEC-2020-5`
- **State:** Confirmed
- **Severity:** CVSS 5.0 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-362](https://cwe.mitre.org/data/definitions/362.html) · [CWE-377](https://cwe.mitre.org/data/definitions/377.html) · [CWE-668](https://cwe.mitre.org/data/definitions/668.html)
- **Tags:** [Race condition](https://agentprime.io/advisories/tag/race-condition.md) · [Information disclosure](https://agentprime.io/advisories/tag/info-disclosure.md) · [CWE-377](https://agentprime.io/advisories/tag/cwe-377.md)
- **Published:** 20 Apr 2021
- **Updated:** 27 Nov 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 20 Apr 2021, 16:46 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `ansible` (PyPI): affected `<2.7.17 || >=2.8.0a1, <2.8.11 || >=2.9.0a1, <2.9.7`; fixed in `2.7.17`, `2.8.11`, `2.9.7`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.0 Medium, CVSS 3.1: `CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:L`, from CNA (redhat)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0040, the 34th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 20 Apr 2021. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-g4mq-6fp5-qwcf](https://github.com/advisories/GHSA-g4mq-6fp5-qwcf)
- [OSV: GHSA-g4mq-6fp5-qwcf](https://osv.dev/vulnerability/GHSA-g4mq-6fp5-qwcf)
- <https://nvd.nist.gov/vuln/detail/CVE-2020-1733>
- <https://github.com/ansible/ansible/issues/67791>
- <https://github.com/ansible/ansible/commit/80b9a0a25c5f75e84aefc8f2b293fb1933b154f2>
- <https://github.com/ansible/ansible/commit/8251d9f4c2bc82632ab992277fcd30ccbf87aa47>
- <https://github.com/ansible/ansible/commit/ecf99d5e1ff732a7777010facd6c98bb0994605e>
- <https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-1733>
- <https://github.com/advisories/GHSA-g4mq-6fp5-qwcf>
- <https://github.com/ansible/ansible>
- <https://github.com/pypa/advisory-database/tree/main/vulns/ansible/PYSEC-2020-5.yaml>
- <https://lists.debian.org/debian-lts-announce/2020/05/msg00005.html>
- <https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/DKPA4KC3OJSUFASUYMG66HKJE7ADNGFW>
- <https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/MRRYUU5ZBLPBXCYG6CFP35D64NP2UB2S>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-g4mq-6fp5-qwcf>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-g4mq-6fp5-qwcf/>. Everything for agents: <https://agentprime.io/llms.txt>.
