# OpenFGA: ListUsers returns a deliberately-excluded user when a \`but not\` exclusion under a type-bound wildcard is intersected (\`and\`) with another relation that also grants that user

Advisory record · `GHSA-g3pg-frfm-pr2m`

- **Identifiers:** `GHSA-g3pg-frfm-pr2m` · `CVE-2026-61709` · `GO-2026-6488`
- **State:** Confirmed
- **Severity:** CVSS 5.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-281](https://cwe.mitre.org/data/definitions/281.html) · [CWE-863](https://cwe.mitre.org/data/definitions/863.html)
- **Tags:** [Broken access control](https://agentprime.io/advisories/tag/access-control.md) · [CWE-281](https://agentprime.io/advisories/tag/cwe-281.md)
- **Published:** 16 Sept 2026
- **Updated:** 28 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 16 Sept 2026, 22:15 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `github.com/openfga/openfga` (Go): affected `<1.18.1`; fixed in `1.18.1`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> OpenFGA versions below 1.18.1 can have the ListUsers API return a user who should have been excluded. This affects models where an intersection includes an exclusion whose base side is granted through a type-bound public wildcard, and the excluded user also holds a concrete grant through another operand of the intersection. The source does not say what an attacker must control to trigger it. Upgrade to OpenFGA 1.18.1 or later.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.3 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0035, the 28th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:12 UTC: First seen by agentprime
- 31 Oct 2026, 14:12 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-g3pg-frfm-pr2m)

## Sources

- [GitHub Advisory Database: GHSA-g3pg-frfm-pr2m](https://github.com/advisories/GHSA-g3pg-frfm-pr2m)
- [OSV: GHSA-g3pg-frfm-pr2m](https://osv.dev/vulnerability/GHSA-g3pg-frfm-pr2m)
- <https://github.com/openfga/openfga/security/advisories/GHSA-g3pg-frfm-pr2m>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-61709>
- <https://github.com/openfga/openfga/commit/171806c93b86bca29e0212ceb8b6ee9c48eb9ac3>
- <https://github.com/openfga/openfga>
- <https://github.com/openfga/openfga/releases/tag/v1.18.1>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-g3pg-frfm-pr2m>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-g3pg-frfm-pr2m/>. Everything for agents: <https://agentprime.io/llms.txt>.
