# HTTP Request Smuggling: Invalid Transfer-Encoding in Waitress

Advisory record · `GHSA-g2xc-35jw-c63p`

- **Identifiers:** `GHSA-g2xc-35jw-c63p` · `CVE-2019-16786` · `PYSEC-2019-137`
- **State:** Confirmed
- **Severity:** CVSS 7.1 High
- **Critical:** No
- **Weakness (CWE):** [CWE-444](https://cwe.mitre.org/data/definitions/444.html)
- **Tags:** [HTTP request smuggling](https://agentprime.io/advisories/tag/request-smuggling.md)
- **Published:** 20 Dec 2019
- **Updated:** 8 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 20 Dec 2019, 23:04 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `waitress` (PyPI): affected `<1.4.0`; fixed in `1.4.0`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.1 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:L/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.024, the 83rd percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 20 Dec 2019. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-g2xc-35jw-c63p](https://github.com/advisories/GHSA-g2xc-35jw-c63p)
- [OSV: GHSA-g2xc-35jw-c63p](https://osv.dev/vulnerability/GHSA-g2xc-35jw-c63p)
- <https://github.com/Pylons/waitress/security/advisories/GHSA-g2xc-35jw-c63p>
- <https://nvd.nist.gov/vuln/detail/CVE-2019-16786>
- <https://github.com/Pylons/waitress/commit/f11093a6b3240fc26830b6111e826128af7771c3>
- <https://access.redhat.com/errata/RHSA-2020:0720>
- <https://docs.pylonsproject.org/projects/waitress/en/latest/#security-fixes>
- <https://github.com/Pylons/waitress>
- <https://github.com/pypa/advisory-database/tree/main/vulns/waitress/PYSEC-2019-137.yaml>
- <https://lists.debian.org/debian-lts-announce/2022/05/msg00011.html>
- <https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/GVDHR2DNKCNQ7YQXISJ45NT4IQDX3LJ7>
- <https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/LYEOTGWJZVKPRXX2HBNVIYWCX73QYPM5>
- <https://www.oracle.com/security-alerts/cpuapr2022.html>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-g2xc-35jw-c63p>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-g2xc-35jw-c63p/>. Everything for agents: <https://agentprime.io/llms.txt>.
