# @vue/server-renderer: XSS via missing CR in attribute-name blacklist

Advisory record · `GHSA-g2v6-rqmx-r4w6`

- **Identifiers:** `GHSA-g2v6-rqmx-r4w6`
- **State:** Confirmed
- **Severity:** CVSS 7.2 High
- **Critical:** No
- **Weakness (CWE):** [CWE-79](https://cwe.mitre.org/data/definitions/79.html) · [CWE-116](https://cwe.mitre.org/data/definitions/116.html)
- **Tags:** [Cross-site scripting (XSS)](https://agentprime.io/advisories/tag/xss.md) · [CWE-116](https://agentprime.io/advisories/tag/cwe-116.md)
- **Published:** 5 Oct 2026
- **Updated:** 5 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 5 Oct 2026, 22:50 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `@vue/server-renderer` (npm): affected `<3.5.42 || >=3.6.0-rc.0, <3.6.0-rc.6`; fixed in `3.5.42`, `3.6.0-rc.6`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Vue's @vue/server-renderer, in versions below 3.5.42 and from 3.6.0-rc.0 up to (but not including) 3.6.0-rc.6, fails to escape or reject carriage return characters in attribute names rendered by ssrRenderAttrs(). An attacker who can influence the keys of an object bound with v-bind could inject attributes and event handlers into server-rendered HTML, leading to cross-site scripting that runs for visitors when the page loads. The fix is to upgrade to 3.5.42 or 3.6.0-rc.6 or later.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.2 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** No score.

## Timeline

- 31 Oct 2026, 13:34 UTC: First seen by agentprime
- 31 Oct 2026, 13:34 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-g2v6-rqmx-r4w6)

## Sources

- [GitHub Advisory Database: GHSA-g2v6-rqmx-r4w6](https://github.com/advisories/GHSA-g2v6-rqmx-r4w6)
- [OSV: GHSA-g2v6-rqmx-r4w6](https://osv.dev/vulnerability/GHSA-g2v6-rqmx-r4w6)
- <https://github.com/vuejs/core/security/advisories/GHSA-g2v6-rqmx-r4w6>
- <https://github.com/vuejs/core/pull/15266>
- <https://github.com/vuejs/core/commit/a2b40db9a83b36ed9da3a16403cf8f040262d73f>
- <https://github.com/vuejs/core>
- <https://github.com/vuejs/core/releases/tag/v3.5.42>
- <https://github.com/vuejs/core/releases/tag/v3.6.0-rc.6>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-g2v6-rqmx-r4w6>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-g2v6-rqmx-r4w6/>. Everything for agents: <https://agentprime.io/llms.txt>.
