# electerm's encrypt method not safe enough

Advisory record · `GHSA-g29v-q6h7-76wh`

- **Identifiers:** `GHSA-g29v-q6h7-76wh` · `CVE-2026-45787`
- **State:** Confirmed
- **Severity:** CVSS 6.0 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-326](https://cwe.mitre.org/data/definitions/326.html) · [CWE-329](https://cwe.mitre.org/data/definitions/329.html) · [CWE-353](https://cwe.mitre.org/data/definitions/353.html) · [CWE-759](https://cwe.mitre.org/data/definitions/759.html) · [CWE-916](https://cwe.mitre.org/data/definitions/916.html)
- **Tags:** [Weak cryptography or TLS](https://agentprime.io/advisories/tag/weak-crypto.md) · [CWE-329](https://agentprime.io/advisories/tag/cwe-329.md) · [CWE-353](https://agentprime.io/advisories/tag/cwe-353.md) · [CWE-759](https://agentprime.io/advisories/tag/cwe-759.md)
- **Published:** 14 May 2026
- **Updated:** 9 Jun 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 14 May 2026, 20:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `electerm` (npm): affected `<3.9.5`; fixed in `3.9.5`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.0 Medium, CVSS 4.0: `CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0010, the 1st percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 14 May 2026. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-g29v-q6h7-76wh](https://github.com/advisories/GHSA-g29v-q6h7-76wh)
- [OSV: GHSA-g29v-q6h7-76wh](https://osv.dev/vulnerability/GHSA-g29v-q6h7-76wh)
- <https://github.com/electerm/electerm/security/advisories/GHSA-g29v-q6h7-76wh>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-45787>
- <https://github.com/electerm/electerm/commit/9dd8295e37d53396b980cd45dfc5ed11ad79b937>
- <https://github.com/electerm/electerm>
- <https://github.com/electerm/electerm/releases/tag/v3.9.5>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-g29v-q6h7-76wh>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-g29v-q6h7-76wh/>. Everything for agents: <https://agentprime.io/llms.txt>.
