# CodeWhale: exec_shell_interact sends LLM-controlled input to a running shell without an approval prompt (privilege escalation)

Advisory record · `GHSA-g29h-pfmp-qp9r`

- **Identifiers:** `GHSA-g29h-pfmp-qp9r` · `CVE-2026-75857`
- **State:** Confirmed
- **Severity:** CVSS 7.3 High
- **Critical:** No
- **Weakness (CWE):** [CWE-269](https://cwe.mitre.org/data/definitions/269.html)
- **Tags:** [Privilege escalation](https://agentprime.io/advisories/tag/privilege-escalation.md)
- **Published:** 4 Sept 2026
- **Updated:** 4 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 4 Sept 2026, 18:02 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `deepseek-tui` (crates.io): affected `>=0.3.10, <=0.8.41`; no fixed version yet
- `deepseek-tui` (npm): affected `>=0.3.10, <0.8.41`; fixed in `0.8.41`
- `codewhale-tui` (crates.io): affected `>=0.8.41, <0.8.64`; fixed in `0.8.64`
- `codewhale` (npm): affected `>=0.8.41, <0.8.64`; fixed in `0.8.64`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.3 High, CVSS 4.0: `CVSS:4.0/AV:L/AC:H/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`, from CNA (VulnCheck)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0015, the 4th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 4 Sept 2026. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-g29h-pfmp-qp9r](https://github.com/advisories/GHSA-g29h-pfmp-qp9r)
- [OSV: GHSA-g29h-pfmp-qp9r](https://osv.dev/vulnerability/GHSA-g29h-pfmp-qp9r)
- <https://github.com/Hmbown/CodeWhale/security/advisories/GHSA-g29h-pfmp-qp9r>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-75857>
- <https://github.com/Hmbown/CodeWhale/commit/57f3c89471e27ac4032d9791f6885e5d4408c381>
- <https://github.com/Hmbown/CodeWhale>
- <https://www.vulncheck.com/advisories/codewhale-before-privilege-escalation-via-exec-shell-interact>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-g29h-pfmp-qp9r>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-g29h-pfmp-qp9r/>. Everything for agents: <https://agentprime.io/llms.txt>.
