# Hashicorp Vault vulnerable to denial of service through memory exhaustion

Advisory record · `GHSA-g233-2p4r-3q7v`

- **Identifiers:** `GHSA-g233-2p4r-3q7v` · `BIT-openbao-2024-8185` · `BIT-vault-2024-8185` · `CVE-2024-8185` · `GO-2024-3246`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-636](https://cwe.mitre.org/data/definitions/636.html)
- **Tags:** [CWE-636](https://agentprime.io/advisories/tag/cwe-636.md)
- **Published:** 31 Oct 2024
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 31 Oct 2024, 18:31 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `github.com/hashicorp/vault` (Go): affected `>=1.2.0, <1.18.1`; fixed in `1.18.1`
- `github.com/openbao/openbao` (Go): affected `<2.0.3`; fixed in `2.0.3`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Hashicorp Vault versions 1.2.0 up to 1.18.1 and OpenBao versions before 2.0.3 are vulnerable when they use the Integrated Storage backend. An attacker who can send a large volume of requests to the Raft cluster join API endpoint can exhaust system memory, potentially crashing the server. Upgrade Vault to 1.18.1 or OpenBao to 2.0.3; the source also lists fixed Vault Enterprise releases 1.17.8 and 1.16.12.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`, from CNA (HashiCorp)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0048, the 41st percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:15 UTC: First seen by agentprime
- 31 Oct 2026, 14:15 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-g233-2p4r-3q7v)

## Sources

- [GitHub Advisory Database: GHSA-g233-2p4r-3q7v](https://github.com/advisories/GHSA-g233-2p4r-3q7v)
- [OSV: GHSA-g233-2p4r-3q7v](https://osv.dev/vulnerability/GHSA-g233-2p4r-3q7v)
- <https://nvd.nist.gov/vuln/detail/CVE-2024-8185>
- <https://github.com/hashicorp/vault/commit/195dfca433028887973f5bd82d173d91fe9dab4a>
- <https://discuss.hashicorp.com/t/hcsec-2024-26-vault-vulnerable-to-denial-of-service-through-memory-exhaustion-when-processing-raft-cluster-join-requests/71047>
- <https://github.com/hashicorp/vault>
- <https://openbao.org/docs/release-notes/2-0-0/#203>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-g233-2p4r-3q7v>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-g233-2p4r-3q7v/>. Everything for agents: <https://agentprime.io/llms.txt>.
