# uap-core Regular Expression Denial of Service issue

Advisory record · `GHSA-fx7m-j728-mjw3`

- **Identifiers:** `GHSA-fx7m-j728-mjw3` · `CVE-2018-20164`
- **State:** Confirmed
- **Severity:** CVSS 5.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-185](https://cwe.mitre.org/data/definitions/185.html)
- **Tags:** [CWE-185](https://agentprime.io/advisories/tag/cwe-185.md)
- **Published:** 6 Mar 2019
- **Updated:** 8 Nov 2023
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 6 Mar 2019, 17:35 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `uap-core` (npm): affected `<0.6.0`; fixed in `0.6.0`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.3 Medium, CVSS 3.0: `CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.033, the 88th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 6 Mar 2019. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-fx7m-j728-mjw3](https://github.com/advisories/GHSA-fx7m-j728-mjw3)
- [OSV: GHSA-fx7m-j728-mjw3](https://osv.dev/vulnerability/GHSA-fx7m-j728-mjw3)
- <https://nvd.nist.gov/vuln/detail/CVE-2018-20164>
- <https://github.com/ua-parser/uap-core/issues/332>
- <https://github.com/ua-parser/uap-core/commit/010ccdc7303546cd22b9da687c29f4a996990014>
- <https://github.com/ua-parser/uap-core/commit/156f7e12b215bddbaf3df4514c399d683e6cdadc>
- <https://github.com/ua-parser/uap-core>
- <https://www.x41-dsec.de/lab/advisories/x41-2018-009-uaparser>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-fx7m-j728-mjw3>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-fx7m-j728-mjw3/>. Everything for agents: <https://agentprime.io/llms.txt>.
