# Panic via negative shared-string index in github.com/xuri/excelize

Advisory record · `GHSA-fx5j-qcqg-grpf`

- **Identifiers:** `GHSA-fx5j-qcqg-grpf` · `CVE-2026-59162` · `GO-2026-6452`
- **State:** Confirmed
- **Severity:** CVSS 6.9 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-248](https://cwe.mitre.org/data/definitions/248.html) · [CWE-755](https://cwe.mitre.org/data/definitions/755.html)
- **Tags:** [CWE-248](https://agentprime.io/advisories/tag/cwe-248.md) · [CWE-755](https://agentprime.io/advisories/tag/cwe-755.md)
- **Published:** 16 Sept 2026
- **Updated:** 24 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 16 Sept 2026, 18:00 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `github.com/xuri/excelize/v2` (Go): affected `<2.11.0`; fixed in `2.11.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Excelize (github.com/xuri/excelize/v2) versions before 2.11.0 panic when a spreadsheet cell contains a negative shared-string index. The shared-string lookup checks only the upper bound, so a negative index passes validation and causes an out-of-bounds access when cells are read through functions such as GetCellValue or GetRows. An attacker who can supply a spreadsheet for the application to parse can crash the process. Upgrade to version 2.11.0 or later.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.9 Medium, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0066, the 51st percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:13 UTC: First seen by agentprime
- 31 Oct 2026, 14:13 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GO-2026-6452)

## Sources

- [GitHub Advisory Database: GHSA-fx5j-qcqg-grpf](https://github.com/advisories/GHSA-fx5j-qcqg-grpf)
- [OSV: GHSA-fx5j-qcqg-grpf](https://osv.dev/vulnerability/GHSA-fx5j-qcqg-grpf)
- <https://github.com/qax-os/excelize/security/advisories/GHSA-fx5j-qcqg-grpf>
- <https://github.com/qax-os/excelize/commit/93f0b3caed37f21ef5079e3259c6c21dcfe68453>
- <https://github.com/qax-os/excelize/pull/2331>
- <https://github.com/qax-os/excelize/releases/tag/v2.11.0>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-fx5j-qcqg-grpf>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-fx5j-qcqg-grpf/>. Everything for agents: <https://agentprime.io/llms.txt>.
