# Yamcs's WebSocket subscription handlers omit the privilege checks their REST siblings enforce

Advisory record · `GHSA-fwww-cp23-7f5g`

- **Identifiers:** `GHSA-fwww-cp23-7f5g` · `CVE-2026-55545`
- **State:** Confirmed
- **Severity:** CVSS 6.5 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-862](https://cwe.mitre.org/data/definitions/862.html)
- **Tags:** [Broken access control](https://agentprime.io/advisories/tag/access-control.md)
- **Published:** 28 Aug 2026
- **Updated:** 28 Aug 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 28 Aug 2026, 17:10 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `org.yamcs:yamcs-core` (Maven): affected `<5.12.8 || >=5.13.0, <5.13.2`; fixed in `5.12.8`, `5.13.2`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Yamcs versions below 5.12.8 and from 5.13.0 before 5.13.2 (Maven package org.yamcs:yamcs-core) have WebSocket subscription handlers for packets, algorithm-status and mdb-changes that skip the privilege checks their REST counterparts enforce. A user with a valid account can subscribe over WebSocket and receive data that the REST API would have restricted or denied, such as raw packet data for a narrow packet-read scope. Upgrade to version 5.12.8 or 5.13.2.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.5 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0045, the 39th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:19 UTC: First seen by agentprime
- 31 Oct 2026, 14:19 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-fwww-cp23-7f5g)

## Sources

- [GitHub Advisory Database: GHSA-fwww-cp23-7f5g](https://github.com/advisories/GHSA-fwww-cp23-7f5g)
- [OSV: GHSA-fwww-cp23-7f5g](https://osv.dev/vulnerability/GHSA-fwww-cp23-7f5g)
- <https://github.com/yamcs/yamcs/security/advisories/GHSA-fwww-cp23-7f5g>
- <https://github.com/yamcs/yamcs/commit/0691731846c5a0aca81b88fabbd2cd51d56fe076>
- <https://github.com/yamcs/yamcs/commit/12864af555e6ca4941b01c1f1217859cc0492ce0>
- <https://github.com/yamcs/yamcs>
- <https://github.com/yamcs/yamcs/releases/tag/yamcs-5.12.8>
- <https://github.com/yamcs/yamcs/releases/tag/yamcs-5.13.2>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-fwww-cp23-7f5g>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-fwww-cp23-7f5g/>. Everything for agents: <https://agentprime.io/llms.txt>.
