# Soft Serve does not sanitize ANSI escape sequences in user input in github.com/charmbracelet/soft-serve

Advisory record · `GHSA-fv2r-r8mp-pg48`

- **Identifiers:** `GHSA-fv2r-r8mp-pg48` · `CVE-2025-64494` · `GO-2025-4106`
- **State:** Confirmed
- **Severity:** CVSS 4.6 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-150](https://cwe.mitre.org/data/definitions/150.html)
- **Tags:** [CWE-150](https://agentprime.io/advisories/tag/cwe-150.md)
- **Published:** 17 Nov 2025
- **Updated:** 3 Mar 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 17 Nov 2025, 19:11 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `github.com/charmbracelet/soft-serve` (Go): affected `<0.11.0`; fixed in `0.11.0`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 4.6 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0019, the 8th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 17 Nov 2025. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-fv2r-r8mp-pg48](https://github.com/advisories/GHSA-fv2r-r8mp-pg48)
- [OSV: GHSA-fv2r-r8mp-pg48](https://osv.dev/vulnerability/GHSA-fv2r-r8mp-pg48)
- <https://github.com/charmbracelet/soft-serve/security/advisories/GHSA-fv2r-r8mp-pg48>
- <https://nvd.nist.gov/vuln/detail/CVE-2025-64494>
- <https://github.com/charmbracelet/soft-serve/commit/d9639320b8d0ccd76fe6836a042c042b0ebde549>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-fv2r-r8mp-pg48>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-fv2r-r8mp-pg48/>. Everything for agents: <https://agentprime.io/llms.txt>.
