# Externally Controlled Reference to a Resource in Another Sphere, Improper Input Validation, and External Control of File Name or Path in Ansible

Advisory record · `GHSA-frxj-5j27-f8rf`

- **Identifiers:** `GHSA-frxj-5j27-f8rf` · `CVE-2019-14905` · `PYSEC-2020-206`
- **State:** Confirmed
- **Severity:** CVSS 7.3 High
- **Critical:** No
- **Weakness (CWE):** [CWE-20](https://cwe.mitre.org/data/definitions/20.html) · [CWE-73](https://cwe.mitre.org/data/definitions/73.html) · [CWE-610](https://cwe.mitre.org/data/definitions/610.html) · [CWE-668](https://cwe.mitre.org/data/definitions/668.html)
- **Tags:** [Path traversal](https://agentprime.io/advisories/tag/path-traversal.md) · [Information disclosure](https://agentprime.io/advisories/tag/info-disclosure.md) · [CWE-20](https://agentprime.io/advisories/tag/cwe-20.md) · [CWE-610](https://agentprime.io/advisories/tag/cwe-610.md)
- **Published:** 20 Apr 2021
- **Updated:** 25 Nov 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 20 Apr 2021, 16:44 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `ansible` (PyPI): affected `>=2.7.0a1, <2.7.16 || >=2.8.0a1, <2.8.8 || >=2.9.0a1, <2.9.3`; fixed in `2.7.16`, `2.8.8`, `2.9.3`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.3 High, CVSS 3.0: `CVSS:3.0/AV:L/AC:L/PR:H/UI:N/S:C/C:H/I:L/A:L`, from CNA (redhat)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0071, the 53rd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 20 Apr 2021. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-frxj-5j27-f8rf](https://github.com/advisories/GHSA-frxj-5j27-f8rf)
- [OSV: GHSA-frxj-5j27-f8rf](https://osv.dev/vulnerability/GHSA-frxj-5j27-f8rf)
- <https://nvd.nist.gov/vuln/detail/CVE-2019-14905>
- <https://access.redhat.com/errata/RHSA-2020:0216>
- <https://access.redhat.com/errata/RHSA-2020:0218>
- <https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14905>
- <https://github.com/advisories/GHSA-frxj-5j27-f8rf>
- <https://github.com/ansible/ansible>
- <https://github.com/pypa/advisory-database/tree/main/vulns/ansible/PYSEC-2020-206.yaml>
- <https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/5BNCYPQ4BY5QHBCJOAOPANB5FHATW2BR>
- <http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00021.html>
- <http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00026.html>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-frxj-5j27-f8rf>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-frxj-5j27-f8rf/>. Everything for agents: <https://agentprime.io/llms.txt>.
