# fluentd vulnerable to remote code execution due to insecure deserialization (in non-default configuration)

Advisory record · `GHSA-fppq-mj76-fpj2`

- **Identifiers:** `GHSA-fppq-mj76-fpj2` · `BIT-fluentd-2022-39379` · `CVE-2022-39379`
- **State:** Confirmed
- **Severity:** CVSS 3.1 Low
- **Critical:** No
- **Weakness (CWE):** [CWE-502](https://cwe.mitre.org/data/definitions/502.html)
- **Tags:** [Insecure deserialization](https://agentprime.io/advisories/tag/deserialization.md)
- **Published:** 2 Nov 2022
- **Updated:** 21 Feb 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 2 Nov 2022, 18:15 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `fluentd` (RubyGems): affected `>=1.13.2, <1.15.3`; fixed in `1.15.3`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 3.1 Low, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.45, the 98th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 2 Nov 2022. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-fppq-mj76-fpj2](https://github.com/advisories/GHSA-fppq-mj76-fpj2)
- [OSV: GHSA-fppq-mj76-fpj2](https://osv.dev/vulnerability/GHSA-fppq-mj76-fpj2)
- <https://github.com/fluent/fluentd/security/advisories/GHSA-fppq-mj76-fpj2>
- <https://nvd.nist.gov/vuln/detail/CVE-2022-39379>
- <https://github.com/fluent/fluentd/commit/48e5b85dab1b6d4c273090d538fc11b3f2fd8135>
- <https://github.com/fluent/fluentd>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/fluentd/CVE-2022-39379.yml>
- <https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/MYD5QV66OLDHES6IKVYYM3Y3YID3VVCO>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-fppq-mj76-fpj2>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-fppq-mj76-fpj2/>. Everything for agents: <https://agentprime.io/llms.txt>.
