# Apache Camel-platform-http-main: when JWT authentication was configured with a keystore but no issuer or audience, the iss and aud claims were never validated, so any unexpired token signed by a trusted key was accepted

Advisory record · `GHSA-fpm2-m4qq-wghr`

- **Identifiers:** `GHSA-fpm2-m4qq-wghr` · `CVE-2026-66908`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-287](https://cwe.mitre.org/data/definitions/287.html)
- **Tags:** [Authentication bypass](https://agentprime.io/advisories/tag/auth-bypass.md)
- **Published:** 24 Aug 2026
- **Updated:** 28 Aug 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 24 Aug 2026, 18:31 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `org.apache.camel:camel-platform-http-main` (Maven): affected `>=4.8.0, <4.22.0`; fixed in `4.22.0`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.0061, the 49th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:19 UTC: First seen by agentprime
- 31 Oct 2026, 14:19 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-fpm2-m4qq-wghr)

## Sources

- [GitHub Advisory Database: GHSA-fpm2-m4qq-wghr](https://github.com/advisories/GHSA-fpm2-m4qq-wghr)
- [OSV: GHSA-fpm2-m4qq-wghr](https://osv.dev/vulnerability/GHSA-fpm2-m4qq-wghr)
- <https://nvd.nist.gov/vuln/detail/CVE-2026-66908>
- <https://github.com/apache/camel/pull/25187>
- <https://github.com/apache/camel/pull/25195>
- <https://github.com/apache/camel/pull/25196>
- <https://github.com/apache/camel/commit/23c6bbf0e026277f03732481f780b9f18044792b>
- <https://github.com/apache/camel/commit/4dbb9387102c102ab207e61c8307a3eaaeec7fcf>
- <https://github.com/apache/camel/commit/a69ff2b4504f9f10d6af6c6837142da6f076bdeb>
- <https://camel.apache.org/security/CVE-2026-66908.html>
- <https://github.com/apache/camel>
- <https://github.com/apache/camel/releases/tag/camel-4.22.0>
- <https://issues.apache.org/jira/browse/CAMEL-24281>
- <http://www.openwall.com/lists/oss-security/2026/08/24/12>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-fpm2-m4qq-wghr>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-fpm2-m4qq-wghr/>. Everything for agents: <https://agentprime.io/llms.txt>.
