# Observable Discrepancy and Observable Timing Discrepancy in Jenkins Configuration as Code Plugin

Advisory record · `GHSA-fpj7-9xm6-8hgr`

- **Identifiers:** `GHSA-fpj7-9xm6-8hgr` · `CVE-2022-23106`
- **State:** Confirmed
- **Severity:** CVSS 3.7 Low
- **Critical:** No
- **Weakness (CWE):** [CWE-203](https://cwe.mitre.org/data/definitions/203.html) · [CWE-208](https://cwe.mitre.org/data/definitions/208.html)
- **Tags:** [Information disclosure](https://agentprime.io/advisories/tag/info-disclosure.md) · [CWE-208](https://agentprime.io/advisories/tag/cwe-208.md)
- **Published:** 21 Jan 2022
- **Updated:** 16 Feb 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 21 Jan 2022, 23:38 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `io.jenkins:configuration-as-code` (Maven): affected `>=1.55, <1.55.1 || >=1.54, <1.54.1 || >=1.48, <1.53.1 || <1.47.1`; fixed in `1.55.1`, `1.54.1`, `1.53.1`, `1.47.1`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 3.7 Low, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.012, the 67th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 21 Jan 2022. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-fpj7-9xm6-8hgr](https://github.com/advisories/GHSA-fpj7-9xm6-8hgr)
- [OSV: GHSA-fpj7-9xm6-8hgr](https://osv.dev/vulnerability/GHSA-fpj7-9xm6-8hgr)
- <https://nvd.nist.gov/vuln/detail/CVE-2022-23106>
- <https://github.com/jenkinsci/configuration-as-code-plugin/commit/4f425675edf77d382a6fd10890f1a704ff3b2277>
- <https://github.com/CVEProject/cvelist/blob/00bfb5abeecc9f553a2f42954ee540e493498ee9/2022/23xxx/CVE-2022-23106.json>
- <https://github.com/jenkinsci/configuration-as-code-plugin>
- <https://www.jenkins.io/security/advisory/2022-01-12/#SECURITY-2141>
- <http://www.openwall.com/lists/oss-security/2022/01/12/6>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-fpj7-9xm6-8hgr>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-fpj7-9xm6-8hgr/>. Everything for agents: <https://agentprime.io/llms.txt>.
