# fast-uri vulnerable to server-side request forgery via repeated hostname percent-decoding

Advisory record · `GHSA-fph4-wmhf-6fwf`

- **Identifiers:** `GHSA-fph4-wmhf-6fwf` · `CVE-2026-75899`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-174](https://cwe.mitre.org/data/definitions/174.html) · [CWE-918](https://cwe.mitre.org/data/definitions/918.html)
- **Tags:** [Server-side request forgery (SSRF)](https://agentprime.io/advisories/tag/ssrf.md) · [CWE-174](https://agentprime.io/advisories/tag/cwe-174.md)
- **Published:** 2 Sept 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 2 Sept 2026, 15:42 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `fast-uri` (npm): affected `>=2.4.1, <2.4.5 || >=3.1.2, <3.1.6 || >=4.0.0, <4.1.3`; fixed in `2.4.5`, `3.1.6`, `4.1.3`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`, from CNA (openjs)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0022, the 12th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 2 Sept 2026. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-fph4-wmhf-6fwf](https://github.com/advisories/GHSA-fph4-wmhf-6fwf)
- [OSV: GHSA-fph4-wmhf-6fwf](https://osv.dev/vulnerability/GHSA-fph4-wmhf-6fwf)
- <https://github.com/fastify/fast-uri/security/advisories/GHSA-fph4-wmhf-6fwf>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-75899>
- <https://github.com/fastify/fast-uri/commit/2642290672e7211c990aaed3749c2ce667d0af4f>
- <https://github.com/fastify/fast-uri/commit/8c15dbe94ec50bb8e595791ebb42c35cef0fd304>
- <https://github.com/fastify/fast-uri/commit/ae92a4c5d8c4b6c9e447f048d5fcbde7eebd5514>
- <https://cna.openjsf.org/security-advisories.html>
- <https://github.com/fastify/fast-uri>
- <https://github.com/fastify/fast-uri/releases/tag/v2.4.5>
- <https://github.com/fastify/fast-uri/releases/tag/v3.1.6>
- <https://github.com/fastify/fast-uri/releases/tag/v4.1.3>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-fph4-wmhf-6fwf>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-fph4-wmhf-6fwf/>. Everything for agents: <https://agentprime.io/llms.txt>.
