# melange: Incomplete package integrity verification allows data section substitution

Advisory record · `GHSA-fpg8-7664-jc5q`

- **Identifiers:** `GHSA-fpg8-7664-jc5q` · `CVE-2026-54174` · `GO-2026-5968`
- **State:** Confirmed
- **Severity:** CVSS 8.3 High
- **Critical:** No
- **Weakness (CWE):** [CWE-345](https://cwe.mitre.org/data/definitions/345.html) · [CWE-354](https://cwe.mitre.org/data/definitions/354.html)
- **Tags:** [CWE-345](https://agentprime.io/advisories/tag/cwe-345.md) · [CWE-354](https://agentprime.io/advisories/tag/cwe-354.md)
- **Published:** 10 Jul 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 10 Jul 2026, 21:43 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `chainguard.dev/apko` (Go): affected `<1.2.9`; fixed in `1.2.9`
- `chainguard.dev/melange` (Go): affected `<0.50.4`; fixed in `0.50.4`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The chainguard.dev/apko Go module before 1.2.9 and chainguard.dev/melange before 0.50.4 check only the control section hash of packages, not the data section. An attacker who can compromise a mirror, poison a cache, or intercept a fetch can substitute the installed file contents. Upgrade apko to 1.2.9 or melange to 0.50.4.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.3 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0015, the 4th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:14 UTC: First seen by agentprime
- 31 Oct 2026, 14:14 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-fpg8-7664-jc5q)

## Sources

- [GitHub Advisory Database: GHSA-fpg8-7664-jc5q](https://github.com/advisories/GHSA-fpg8-7664-jc5q)
- [OSV: GHSA-fpg8-7664-jc5q](https://osv.dev/vulnerability/GHSA-fpg8-7664-jc5q)
- <https://github.com/chainguard-dev/melange/security/advisories/GHSA-fpg8-7664-jc5q>
- <https://github.com/chainguard-dev/melange>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-fpg8-7664-jc5q>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-fpg8-7664-jc5q/>. Everything for agents: <https://agentprime.io/llms.txt>.
