# social-auth-core Vulnerable to Account Takeover via Identity Binding Flaw in Vend Backend

Advisory record · `GHSA-fp7w-m676-w7gc`

- **Identifiers:** `GHSA-fp7w-m676-w7gc` · `CVE-2026-57176` · `PYSEC-2026-4166`
- **State:** Confirmed
- **Severity:** CVSS 6.8 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-289](https://cwe.mitre.org/data/definitions/289.html)
- **Tags:** [CWE-289](https://agentprime.io/advisories/tag/cwe-289.md)
- **Published:** 24 Sept 2026
- **Updated:** 1 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 24 Sept 2026, 19:55 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `social-auth-core` (PyPI): affected `<5.0.0`; fixed in `5.0.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The Vend OAuth2 backend in social-auth-core, versions before 5.0.0, identified users only by their numeric Vend user ID, so accounts from different Vend shops could collide. An attacker who has a Vend account in one shop can be authenticated as a local account linked to the same numeric user ID from another shop, which is an account takeover. Upgrade to social-auth-core 5.0.0 or later; if upgrading is not possible, restrict the Vend backend to a single trusted shop or disable it.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.8 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0022, the 12th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:09 UTC: First seen by agentprime
- 31 Oct 2026, 14:09 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-fp7w-m676-w7gc)

## Sources

- [GitHub Advisory Database: GHSA-fp7w-m676-w7gc](https://github.com/advisories/GHSA-fp7w-m676-w7gc)
- [OSV: GHSA-fp7w-m676-w7gc](https://osv.dev/vulnerability/GHSA-fp7w-m676-w7gc)
- <https://github.com/python-social-auth/social-core/security/advisories/GHSA-fp7w-m676-w7gc>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-57176>
- <https://github.com/python-social-auth/social-core/pull/1795>
- <https://github.com/python-social-auth/social-core/commit/dee7ad1785877afd355dd6860598823d2631b76e>
- <https://github.com/python-social-auth/social-core>
- <https://github.com/python-social-auth/social-core/releases/tag/5.0.0>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-fp7w-m676-w7gc>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-fp7w-m676-w7gc/>. Everything for agents: <https://agentprime.io/llms.txt>.
