# Auth0 laravel-auth0 SDK has Insufficient Entropy in Cookie Encryption

Advisory record · `GHSA-fmg6-246m-9g2v`

- **Identifiers:** `GHSA-fmg6-246m-9g2v` · `PKSA-9fpd-p7cq-9hfg`
- **State:** Confirmed
- **Severity:** CVSS 8.2 High
- **Critical:** No
- **Weakness (CWE):** [CWE-331](https://cwe.mitre.org/data/definitions/331.html)
- **Tags:** [CWE-331](https://agentprime.io/advisories/tag/cwe-331.md)
- **Published:** 3 Apr 2026
- **Updated:** 3 Apr 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 3 Apr 2026, 03:41 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `auth0/login` (Packagist): affected `>=7.0.0, <7.21.0`; fixed in `7.21.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Auth0's laravel-auth0 SDK (auth0/login) versions 7.0.0 through 7.20.0 encrypt cookies with insufficient entropy. An attacker may be able to brute-force the encryption key and forge session cookies. Upgrade to version 7.21.0 or later.

Written 3 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.2 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** No score.

## Timeline

- 31 Oct 2026, 14:25 UTC: First seen by agentprime
- 31 Oct 2026, 14:25 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-fmg6-246m-9g2v)

## Sources

- [GitHub Advisory Database: GHSA-fmg6-246m-9g2v](https://github.com/advisories/GHSA-fmg6-246m-9g2v)
- [OSV: GHSA-fmg6-246m-9g2v](https://osv.dev/vulnerability/GHSA-fmg6-246m-9g2v)
- <https://github.com/auth0/laravel-auth0/security/advisories/GHSA-fmg6-246m-9g2v>
- <https://github.com/auth0/laravel-auth0>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-fmg6-246m-9g2v>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-fmg6-246m-9g2v/>. Everything for agents: <https://agentprime.io/llms.txt>.
