# GeoServer is vulnerable to Unauthenticated XML External Entities (XXE) attack via WMS GetMap feature

Advisory record · `GHSA-fjf5-xgmq-5525`

- **Identifiers:** `GHSA-fjf5-xgmq-5525` · `CVE-2025-58360`
- **State:** Confirmed
- **Severity:** CVSS 8.2 High
- **Critical:** Yes: KEV, CVSS 7+ and EPSS
- **Weakness (CWE):** [CWE-611](https://cwe.mitre.org/data/definitions/611.html)
- **Tags:** [XML external entities (XXE)](https://agentprime.io/advisories/tag/xxe.md)
- **Published:** 25 Nov 2025
- **Updated:** 11 Dec 2025
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 25 Nov 2025, 19:07 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- In CISA’s KEV catalogue since 11 Dec 2025: it is known to be exploited.
- CVSS score 8.2 (7.0 or more) and EPSS 0.61 (0.1 or more): a high score and a real chance of exploitation in the next 30 days.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `org.geoserver.web:gs-web-app` (Maven): affected `>=2.26.0, <2.26.2 || <2.25.6`; fixed in `2.26.2`, `2.25.6`
- `org.geoserver:gs-wms` (Maven): affected `>=2.26.0, <2.26.2 || <2.25.6`; fixed in `2.26.2`, `2.25.6`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> GeoServer (packages gs-web-app and gs-wms) versions 2.26.0 up to 2.26.2 and versions before 2.25.6 are affected. The WMS GetMap operation accepts XML input without adequate restriction on external entities, so an unauthenticated attacker can send a crafted request to read arbitrary files from the server, perform server-side request forgery against internal systems, or cause denial of service. Upgrade to 2.25.6 or 2.26.3 or later; the source lists 2.26.2 as a fixed version for these packages but its resolution names 2.26.3 and 2.27.0.

Written 7 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.2 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:L`, from CNA (GitHub_M)

- **CISA KEV:** Listed since 11 Dec 2025: known to be exploited.
- **EPSS:** 0.61, the 99th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:09 UTC: First seen by agentprime
- 31 Oct 2026, 15:09 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-fjf5-xgmq-5525)

## Sources

- [GitHub Advisory Database: GHSA-fjf5-xgmq-5525](https://github.com/advisories/GHSA-fjf5-xgmq-5525)
- [OSV: GHSA-fjf5-xgmq-5525](https://osv.dev/vulnerability/GHSA-fjf5-xgmq-5525)
- <https://github.com/geoserver/geoserver/security/advisories/GHSA-fjf5-xgmq-5525>
- <https://nvd.nist.gov/vuln/detail/CVE-2025-58360>
- <https://github.com/geoserver/geoserver>
- <https://osgeo-org.atlassian.net/browse/GEOS-11682>
- <https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-58360>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-fjf5-xgmq-5525>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-fjf5-xgmq-5525/>. Everything for agents: <https://agentprime.io/llms.txt>.
