# CommandKit has incorrect command name exposure in context object for message command aliases

Advisory record · `GHSA-fhwm-pc6r-4h2f`

- **Identifiers:** `GHSA-fhwm-pc6r-4h2f` · `CVE-2025-62378`
- **State:** Confirmed
- **Severity:** CVSS 6.1 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-706](https://cwe.mitre.org/data/definitions/706.html)
- **Tags:** [CWE-706](https://agentprime.io/advisories/tag/cwe-706.md)
- **Published:** 13 Oct 2025
- **Updated:** 16 Oct 2025
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 13 Oct 2025, 17:43 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `commandkit` (npm): affected `>=1.2.0-rc.1, <1.2.0-rc.12`; fixed in `1.2.0-rc.12`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.1 Medium, CVSS 3.1: `CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0017, the 6th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 13 Oct 2025. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-fhwm-pc6r-4h2f](https://github.com/advisories/GHSA-fhwm-pc6r-4h2f)
- [OSV: GHSA-fhwm-pc6r-4h2f](https://osv.dev/vulnerability/GHSA-fhwm-pc6r-4h2f)
- <https://github.com/underctrl-io/commandkit/security/advisories/GHSA-fhwm-pc6r-4h2f>
- <https://nvd.nist.gov/vuln/detail/CVE-2025-62378>
- <https://github.com/underctrl-io/commandkit/commit/440385a3e5de3fa3d2a76d23a807995cb29602fd>
- <https://github.com/underctrl-io/commandkit>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-fhwm-pc6r-4h2f>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-fhwm-pc6r-4h2f/>. Everything for agents: <https://agentprime.io/llms.txt>.
