# nginx-ui Backup Restore Allows Tampering with Encrypted Backups

Advisory record · `GHSA-fhh2-gg7w-gwpq`

- **Identifiers:** `GHSA-fhh2-gg7w-gwpq` · `CVE-2026-33026` · `GO-2026-4903`
- **State:** Confirmed
- **Severity:** CVSS 9.4 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-312](https://cwe.mitre.org/data/definitions/312.html) · [CWE-347](https://cwe.mitre.org/data/definitions/347.html) · [CWE-354](https://cwe.mitre.org/data/definitions/354.html)
- **Tags:** [Information disclosure](https://agentprime.io/advisories/tag/info-disclosure.md) · [Weak cryptography or TLS](https://agentprime.io/advisories/tag/weak-crypto.md) · [CWE-354](https://agentprime.io/advisories/tag/cwe-354.md)
- **Published:** 30 Mar 2026
- **Updated:** 6 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 30 Mar 2026, 16:23 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.4: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `github.com/0xJacky/Nginx-UI` (Go): affected `<1.9.10-0.20260315015203-f61bcec547c0`; fixed in `1.9.10-0.20260315015203-f61bcec547c0`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.4 Critical, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0033, the 26th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:06 UTC: First seen by agentprime
- 31 Oct 2026, 15:06 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-fhh2-gg7w-gwpq)

## Sources

- [GitHub Advisory Database: GHSA-fhh2-gg7w-gwpq](https://github.com/advisories/GHSA-fhh2-gg7w-gwpq)
- [OSV: GHSA-fhh2-gg7w-gwpq](https://osv.dev/vulnerability/GHSA-fhh2-gg7w-gwpq)
- <https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-fhh2-gg7w-gwpq>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-33026>
- <https://github.com/0xJacky/nginx-ui/commit/f61bcec547c0f305e35348d6440ef156c1d5c3cb>
- <https://github.com/0xJacky/nginx-ui>
- <https://github.com/0xJacky/nginx-ui/releases/tag/v2.3.4>
- <https://github.com/advisories/GHSA-g9w5-qffc-6762>
- <https://pkg.go.dev/vuln/GO-2026-4903>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-fhh2-gg7w-gwpq>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-fhh2-gg7w-gwpq/>. Everything for agents: <https://agentprime.io/llms.txt>.
