# kin-openapi: Unauthenticated panic (DoS) in openapi3filter legacy router via non-canonical/unsupported HTTP method on a static path

Advisory record · `GHSA-fh4f-47mf-f2gj`

- **Identifiers:** `GHSA-fh4f-47mf-f2gj` · `CVE-2026-100347` · `GO-2026-6783`
- **State:** Confirmed
- **Severity:** CVSS 5.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-20](https://cwe.mitre.org/data/definitions/20.html) · [CWE-248](https://cwe.mitre.org/data/definitions/248.html)
- **Tags:** [CWE-20](https://agentprime.io/advisories/tag/cwe-20.md) · [CWE-248](https://agentprime.io/advisories/tag/cwe-248.md)
- **Published:** 15 Oct 2026
- **Updated:** 5 Nov 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 15 Oct 2026, 20:15 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `github.com/getkin/kin-openapi` (Go): affected `<0.145.0`; fixed in `0.145.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> kin-openapi, Go module github.com/getkin/kin-openapi, versions before 0.145.0, is vulnerable: a request with a non-standard or differently cased HTTP method (such as PROPFIND or lowercase get) sent to an existing static path behind the openapi3filter ValidationHandler causes a panic. No authentication is needed, so a remote attacker can trigger repeated per-connection panics and log growth, causing denial of service. Upgrade to version 0.145.0 or later.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.3 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0052, the 44th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:12 UTC: First seen by agentprime
- 31 Oct 2026, 14:12 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-fh4f-47mf-f2gj)

## Sources

- [GitHub Advisory Database: GHSA-fh4f-47mf-f2gj](https://github.com/advisories/GHSA-fh4f-47mf-f2gj)
- [OSV: GHSA-fh4f-47mf-f2gj](https://osv.dev/vulnerability/GHSA-fh4f-47mf-f2gj)
- <https://github.com/getkin/kin-openapi/security/advisories/GHSA-fh4f-47mf-f2gj>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-100347>
- <https://github.com/getkin/kin-openapi/commit/f1a5b523b82868d2d9be2e116b4e942892be72c3>
- <https://github.com/getkin/kin-openapi>
- <https://github.com/getkin/kin-openapi/releases/tag/v0.145.0>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-fh4f-47mf-f2gj>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-fh4f-47mf-f2gj/>. Everything for agents: <https://agentprime.io/llms.txt>.
