# authd: Primary group ID is incorrectly set to value of UID

Advisory record · `GHSA-fg3j-5w9g-hmg7`

- **Identifiers:** `GHSA-fg3j-5w9g-hmg7` · `CVE-2026-6970` · `GO-2026-5361`
- **State:** Confirmed
- **Severity:** CVSS 7.3 High
- **Critical:** No
- **Weakness (CWE):** [CWE-842](https://cwe.mitre.org/data/definitions/842.html)
- **Tags:** [CWE-842](https://agentprime.io/advisories/tag/cwe-842.md)
- **Published:** 5 May 2026
- **Updated:** 25 Jun 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 5 May 2026, 22:04 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `github.com/canonical/authd` (Go): affected `>=0.6.0, <0.6.4`; fixed in `0.6.4`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.3 High, CVSS 4.0: `CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`, from CNA (canonical)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0011, the 1st percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:07 UTC: First seen by agentprime
- 31 Oct 2026, 15:07 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-fg3j-5w9g-hmg7)

## Sources

- [GitHub Advisory Database: GHSA-fg3j-5w9g-hmg7](https://github.com/advisories/GHSA-fg3j-5w9g-hmg7)
- [OSV: GHSA-fg3j-5w9g-hmg7](https://osv.dev/vulnerability/GHSA-fg3j-5w9g-hmg7)
- <https://github.com/canonical/authd/security/advisories/GHSA-fg3j-5w9g-hmg7>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-6970>
- <https://github.com/canonical/authd/commit/154b428305cb1a7a19c897626fefd09d6dde8b9f>
- <https://github.com/canonical/authd>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-fg3j-5w9g-hmg7>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-fg3j-5w9g-hmg7/>. Everything for agents: <https://agentprime.io/llms.txt>.
