# Auth0 Symfony SDK Accepted Bearer Tokens via URL Query Parameter

Advisory record · `GHSA-ffq7-hh2j-r24p`

- **Identifiers:** `GHSA-ffq7-hh2j-r24p` · `CVE-2026-50157` · `PKSA-nrzm-zxwz-yhq9`
- **State:** Confirmed
- **Severity:** CVSS 6.5 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-200](https://cwe.mitre.org/data/definitions/200.html) · [CWE-598](https://cwe.mitre.org/data/definitions/598.html)
- **Tags:** [Information disclosure](https://agentprime.io/advisories/tag/info-disclosure.md) · [CWE-598](https://agentprime.io/advisories/tag/cwe-598.md)
- **Published:** 14 Jul 2026
- **Updated:** 28 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 14 Jul 2026, 19:31 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `auth0/symfony` (Packagist): affected `>=5.0.0-BETA0, <5.9.0`; fixed in `5.9.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The auth0/symfony package, versions 5.0.0-BETA0 up to 5.9.0 (not including 5.9.0), accepts OAuth 2.0 bearer access tokens passed as a URL query parameter in addition to the Authorization header when the Authorizer security authenticator protects HTTP routes. The source does not describe the attacker's position or prerequisites, but the issue may increase the risk of access token exposure and replay against protected API endpoints. Upgrade auth0/symfony to version 5.9.0 or greater.

Written 3 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.5 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0051, the 43rd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:24 UTC: First seen by agentprime
- 31 Oct 2026, 14:24 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-ffq7-hh2j-r24p)

## Sources

- [GitHub Advisory Database: GHSA-ffq7-hh2j-r24p](https://github.com/advisories/GHSA-ffq7-hh2j-r24p)
- [OSV: GHSA-ffq7-hh2j-r24p](https://osv.dev/vulnerability/GHSA-ffq7-hh2j-r24p)
- <https://github.com/auth0/symfony/security/advisories/GHSA-ffq7-hh2j-r24p>
- <https://github.com/auth0/symfony/commit/172d1d3e0b9d1e93610d786118389a811179bc8a>
- <https://github.com/auth0/symfony/commit/bd1851b14ae15e99cbe87c96496cf25da025288a>
- <https://github.com/auth0/symfony>
- <https://github.com/auth0/symfony/releases/tag/5.9.0>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-ffq7-hh2j-r24p>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-ffq7-hh2j-r24p/>. Everything for agents: <https://agentprime.io/llms.txt>.
