# Jupyter Server: Stored XSS in \`NbconvertFileHandler\` / \`NbconvertPostHandler\` via missing \`sandbox\` CSP

Advisory record · `GHSA-fcw5-x6j4-ccmp`

- **Identifiers:** `GHSA-fcw5-x6j4-ccmp` · `CVE-2026-44727` · `PYSEC-2026-366`
- **State:** Confirmed
- **Severity:** CVSS 9.3 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-79](https://cwe.mitre.org/data/definitions/79.html) · [CWE-1021](https://cwe.mitre.org/data/definitions/1021.html)
- **Tags:** [Cross-site scripting (XSS)](https://agentprime.io/advisories/tag/xss.md) · [CWE-1021](https://agentprime.io/advisories/tag/cwe-1021.md)
- **Published:** 18 Jun 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 18 Jun 2026, 15:04 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.3: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `jupyter-server` (PyPI): affected `<2.20.0`; fixed in `2.20.0`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.3 Critical, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0044, the 38th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:29 UTC: First seen by agentprime
- 31 Oct 2026, 14:29 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-fcw5-x6j4-ccmp)

## Sources

- [GitHub Advisory Database: GHSA-fcw5-x6j4-ccmp](https://github.com/advisories/GHSA-fcw5-x6j4-ccmp)
- [OSV: GHSA-fcw5-x6j4-ccmp](https://osv.dev/vulnerability/GHSA-fcw5-x6j4-ccmp)
- <https://github.com/jupyter-server/jupyter_server/security/advisories/GHSA-fcw5-x6j4-ccmp>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-44727>
- <https://github.com/jupyter-server/jupyter_server/commit/6cbee8d65e71abac851c4492fea987ad080580bd>
- <https://access.redhat.com/errata/RHSA-2026:43038>
- <https://access.redhat.com/errata/RHSA-2026:60520>
- <https://access.redhat.com/security/cve/CVE-2026-44727>
- <https://bugzilla.redhat.com/show_bug.cgi?id=2491516>
- <https://github.com/advisories/GHSA-fcw5-x6j4-ccmp>
- <https://github.com/jupyter-server/jupyter_server>
- <https://github.com/pypa/advisory-database/tree/main/vulns/jupyter-server/PYSEC-2026-366.yaml>
- <https://pypi.org/project/jupyter-server>
- <https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-44727.json>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-fcw5-x6j4-ccmp>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-fcw5-x6j4-ccmp/>. Everything for agents: <https://agentprime.io/llms.txt>.
