# Apache Tomcat Improper Input Validation vulnerability

Advisory record · `GHSA-fccv-jmmp-qg76`

- **Identifiers:** `GHSA-fccv-jmmp-qg76` · `BIT-tomcat-2023-46589` · `CVE-2023-46589`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-20](https://cwe.mitre.org/data/definitions/20.html) · [CWE-444](https://cwe.mitre.org/data/definitions/444.html)
- **Tags:** [HTTP request smuggling](https://agentprime.io/advisories/tag/request-smuggling.md) · [CWE-20](https://agentprime.io/advisories/tag/cwe-20.md)
- **Published:** 28 Nov 2023
- **Updated:** 2 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 28 Nov 2023, 18:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `org.apache.tomcat:tomcat-catalina` (Maven): affected `>=11.0.0-M1, <11.0.0-M11 || >=10.1.0-M1, <10.1.16 || >=9.0.0-M1, <9.0.83 || >=8.5.0, <8.5.96`; fixed in `11.0.0-M11`, `10.1.16`, `9.0.83`, `8.5.96`
- `org.apache.tomcat.embed:tomcat-embed-core` (Maven): affected `>=11.0.0-M1, <11.0.0-M11 || >=10.1.0-M1, <10.1.16 || >=9.0.0-M1, <9.0.83 || >=8.5.0, <8.5.96`; fixed in `11.0.0-M11`, `10.1.16`, `9.0.83`, `8.5.96`
- `org.apache.tomcat:tomcat-coyote` (Maven): affected `>=11.0.0-M1, <11.0.0-M11`; fixed in `11.0.0-M11`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Apache Tomcat versions 11.0.0-M1 through 11.0.0-M10, 10.1.0-M1 through 10.1.15, 9.0.0-M1 through 9.0.82, and 8.5.0 through 8.5.95 are affected, along with the tomcat-catalina, tomcat-embed-core and tomcat-coyote packages. A trailer header larger than the size limit can cause one request to be treated as several, enabling request smuggling when Tomcat sits behind a reverse proxy. Upgrade to 11.0.0-M11, 10.1.16, 9.0.83 or 8.5.96 or later, which fix the issue. Older, end-of-life versions may also be affected and have no fix listed.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.027, the 85th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:16 UTC: First seen by agentprime
- 31 Oct 2026, 14:16 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-fccv-jmmp-qg76)

## Sources

- [GitHub Advisory Database: GHSA-fccv-jmmp-qg76](https://github.com/advisories/GHSA-fccv-jmmp-qg76)
- [OSV: GHSA-fccv-jmmp-qg76](https://osv.dev/vulnerability/GHSA-fccv-jmmp-qg76)
- <https://nvd.nist.gov/vuln/detail/CVE-2023-46589>
- <https://github.com/apache/tomcat/commit/6f181e1062a472bc5f0234980f66cbde42c1041b>
- <https://github.com/apache/tomcat/commit/7a2d8818fcea0b51747a67af9510ce7977245ebd>
- <https://github.com/apache/tomcat/commit/aa92971e879a519384c517febc39fd04c48d4642>
- <https://github.com/apache/tomcat/commit/b5776d769bffeade865061bc8ecbeb2b56167b08>
- <https://github.com/apache/tomcat>
- <https://lists.apache.org/thread/0rqq6ktozqc42ro8hhxdmmdjm1k1tpxr>
- <https://lists.debian.org/debian-lts-announce/2024/01/msg00001.html>
- <https://security.netapp.com/advisory/ntap-20231214-0009>
- <https://tomcat.apache.org/security-10.html>
- <https://tomcat.apache.org/security-11.html>
- <https://tomcat.apache.org/security-8.html>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-fccv-jmmp-qg76>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-fccv-jmmp-qg76/>. Everything for agents: <https://agentprime.io/llms.txt>.
