# Decidim has a cross-site scripting (XSS) in user name

Advisory record · `GHSA-fc46-r95f-hq7g`

- **Identifiers:** `GHSA-fc46-r95f-hq7g` · `CVE-2026-23891`
- **State:** Confirmed
- **Severity:** CVSS 9.3 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-79](https://cwe.mitre.org/data/definitions/79.html)
- **Tags:** [Cross-site scripting (XSS)](https://agentprime.io/advisories/tag/xss.md)
- **Published:** 13 Apr 2026
- **Updated:** 13 May 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 13 Apr 2026, 16:35 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.3: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `decidim-core` (RubyGems): affected `>=0.31.0.rc1, <0.31.1 || <0.30.5`; fixed in `0.31.1`, `0.30.5`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.3 Critical, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:L/SC:H/SI:H/SA:L`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0036, the 29th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 13 Apr 2026. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-fc46-r95f-hq7g](https://github.com/advisories/GHSA-fc46-r95f-hq7g)
- [OSV: GHSA-fc46-r95f-hq7g](https://osv.dev/vulnerability/GHSA-fc46-r95f-hq7g)
- <https://github.com/decidim/decidim/security/advisories/GHSA-fc46-r95f-hq7g>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-23891>
- <https://github.com/decidim/decidim>
- <https://github.com/decidim/decidim/releases/tag/v0.30.5>
- <https://github.com/decidim/decidim/releases/tag/v0.31.1>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/decidim-core/CVE-2026-23891.yml>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-fc46-r95f-hq7g>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-fc46-r95f-hq7g/>. Everything for agents: <https://agentprime.io/llms.txt>.
