# Misinterpretation of Input in thorsten/phpmyfaq

Advisory record · `GHSA-f9c6-4j9h-6c5r`

- **Identifiers:** `GHSA-f9c6-4j9h-6c5r` · `CVE-2023-0880` · `PKSA-gpfr-w2p1-4v7c`
- **State:** Confirmed
- **Severity:** CVSS 8.3 High
- **Critical:** No
- **Weakness (CWE):** [CWE-115](https://cwe.mitre.org/data/definitions/115.html)
- **Tags:** [CWE-115](https://agentprime.io/advisories/tag/cwe-115.md)
- **Published:** 17 Feb 2023
- **Updated:** 8 Nov 2023
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 17 Feb 2023, 03:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `thorsten/phpmyfaq` (Packagist): affected `<3.1.11`; fixed in `3.1.11`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The thorsten/phpmyfaq package is vulnerable in versions before 3.1.11. The source gives few details beyond describing a misinterpretation of input, so the attack conditions and impact are not stated. Upgrade to version 3.1.11 or later.

Written 5 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.3 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L`, from CNA (@huntr_ai)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0061, the 49th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:32 UTC: First seen by agentprime
- 31 Oct 2026, 14:32 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-f9c6-4j9h-6c5r)

## Sources

- [GitHub Advisory Database: GHSA-f9c6-4j9h-6c5r](https://github.com/advisories/GHSA-f9c6-4j9h-6c5r)
- [OSV: GHSA-f9c6-4j9h-6c5r](https://osv.dev/vulnerability/GHSA-f9c6-4j9h-6c5r)
- <https://nvd.nist.gov/vuln/detail/CVE-2023-0880>
- <https://github.com/thorsten/phpmyfaq/commit/a67dca41576834a1ddfee61b9e799b686b75d4fa>
- <https://github.com/thorsten/phpMyFAQ>
- <https://huntr.dev/bounties/14fc4841-0f5d-4e12-bf9e-1b60d2ac6a6c>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-f9c6-4j9h-6c5r>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-f9c6-4j9h-6c5r/>. Everything for agents: <https://agentprime.io/llms.txt>.
