# Apache Kyuubi Server vulnerable to Path Traversal

Advisory record · `GHSA-f8r6-6222-9pvc`

- **Identifiers:** `GHSA-f8r6-6222-9pvc` · `CVE-2025-66518`
- **State:** Confirmed
- **Severity:** CVSS 8.8 High
- **Critical:** No
- **Weakness (CWE):** [CWE-22](https://cwe.mitre.org/data/definitions/22.html) · [CWE-27](https://cwe.mitre.org/data/definitions/27.html)
- **Tags:** [Path traversal](https://agentprime.io/advisories/tag/path-traversal.md) · [CWE-27](https://agentprime.io/advisories/tag/cwe-27.md)
- **Published:** 5 Jan 2026
- **Updated:** 3 Feb 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 5 Jan 2026, 09:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `org.apache.kyuubi:kyuubi-server_2.12` (Maven): affected `>=1.6.0, <1.10.3`; fixed in `1.10.3`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.8 High, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:H/VI:H/VA:L/SC:H/SI:H/SA:L`, from CNA (apache)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0100, the 62nd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:09 UTC: First seen by agentprime
- 31 Oct 2026, 15:09 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-f8r6-6222-9pvc)

## Sources

- [GitHub Advisory Database: GHSA-f8r6-6222-9pvc](https://github.com/advisories/GHSA-f8r6-6222-9pvc)
- [OSV: GHSA-f8r6-6222-9pvc](https://osv.dev/vulnerability/GHSA-f8r6-6222-9pvc)
- <https://nvd.nist.gov/vuln/detail/CVE-2025-66518>
- <https://github.com/apache/kyuubi>
- <https://lists.apache.org/thread/xp460bwbyzdhho34ljd4nchyt2fmhodl>
- <http://www.openwall.com/lists/oss-security/2026/01/05/1>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-f8r6-6222-9pvc>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-f8r6-6222-9pvc/>. Everything for agents: <https://agentprime.io/llms.txt>.
