# sharp inherited vulnerabilities in libvips: CVE-2026-33327, CVE-2026-33328, CVE-2026-35590, CVE-2026-35591

Advisory record · `GHSA-f88m-g3jw-g9cj`

- **Identifiers:** `GHSA-f88m-g3jw-g9cj` · `CVE-2026-114113`
- **State:** Confirmed
- **Severity:** CVSS 8.4 High
- **Critical:** No
- **Weakness (CWE):** [CWE-1395](https://cwe.mitre.org/data/definitions/1395.html)
- **Tags:** [CWE-1395](https://agentprime.io/advisories/tag/cwe-1395.md)
- **Published:** 21 Jul 2026
- **Updated:** 21 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 21 Jul 2026, 22:07 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `sharp` (npm): affected `<0.35.0`; fixed in `0.35.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The npm package sharp, versions before 0.35.0, is affected by several vulnerabilities inherited from the upstream libvips dependency, two of which are rated High under CVSSv4. An attacker who can get sharp to process untrusted images could be affected, and the advisory does not describe the specific impact of each flaw beyond this. Upgrade sharp to 0.35.0 or later; the source names 0.35.3, which bundles libvips 8.18.3. Users with a globally installed libvips should move to libvips 8.18.3, and the source also describes a workaround that disables decoding of GIF, TIFF and VIPS images.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.4 High, CVSS 4.0: `CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:H/VA:H/SC:L/SI:H/SA:H`, from CNA (VulnCheck)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0011, the 1st percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 13:33 UTC: First seen by agentprime
- 31 Oct 2026, 13:33 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-f88m-g3jw-g9cj)

## Sources

- [GitHub Advisory Database: GHSA-f88m-g3jw-g9cj](https://github.com/advisories/GHSA-f88m-g3jw-g9cj)
- [OSV: GHSA-f88m-g3jw-g9cj](https://osv.dev/vulnerability/GHSA-f88m-g3jw-g9cj)
- <https://github.com/libvips/libvips/security/advisories/GHSA-2fcj-gj27-279x>
- <https://github.com/libvips/libvips/security/advisories/GHSA-523x-vhfw-6r76>
- <https://github.com/libvips/libvips/security/advisories/GHSA-jmwm-wc68-mhwm>
- <https://github.com/libvips/libvips/security/advisories/GHSA-r98w-4fp7-m9c7>
- <https://github.com/lovell/sharp/security/advisories/GHSA-f88m-g3jw-g9cj>
- <https://github.com/lovell/sharp>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-f88m-g3jw-g9cj>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-f88m-g3jw-g9cj/>. Everything for agents: <https://agentprime.io/llms.txt>.
