# undici vulnerable to Subresource Integrity bypass via non-lowercase algorithm tokens

Advisory record · `GHSA-f72v-6w45-q472`

- **Identifiers:** `GHSA-f72v-6w45-q472` · `CVE-2026-109841`
- **State:** Confirmed
- **Severity:** CVSS 5.9 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-178](https://cwe.mitre.org/data/definitions/178.html)
- **Tags:** [CWE-178](https://agentprime.io/advisories/tag/cwe-178.md)
- **Published:** 23 Oct 2026
- **Updated:** 23 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 23 Oct 2026, 22:12 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `undici` (npm): affected `>=7.15.0, <7.30.1 || >=8.0.0, <8.12.2`; fixed in `7.30.1`, `8.12.2`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.9 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N`, from CNA (openjs)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0025, the 16th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 13:33 UTC: First seen by agentprime
- 31 Oct 2026, 13:33 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-f72v-6w45-q472)

## Sources

- [GitHub Advisory Database: GHSA-f72v-6w45-q472](https://github.com/advisories/GHSA-f72v-6w45-q472)
- [OSV: GHSA-f72v-6w45-q472](https://osv.dev/vulnerability/GHSA-f72v-6w45-q472)
- <https://github.com/nodejs/undici/security/advisories/GHSA-f72v-6w45-q472>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-109841>
- <https://github.com/nodejs/undici/commit/18bc8a1e09d15bc45815154a289dcf6fd5254d00>
- <https://github.com/nodejs/undici/commit/4f7ef6806e532ab9e29ccd6229b1b9d241e1b1f0>
- <https://cna.openjsf.org/security-advisories.html>
- <https://github.com/nodejs/undici>
- <https://github.com/nodejs/undici/releases/tag/v7.30.1>
- <https://github.com/nodejs/undici/releases/tag/v8.12.2>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-f72v-6w45-q472>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-f72v-6w45-q472/>. Everything for agents: <https://agentprime.io/llms.txt>.
