# Meridian: Multiple defense-in-depth gaps (collection/depth caps, telemetry, retry, fan-out)

Advisory record · `GHSA-f5v8-v6q3-q4h6`

- **Identifiers:** `GHSA-f5v8-v6q3-q4h6`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-209](https://cwe.mitre.org/data/definitions/209.html) · [CWE-400](https://cwe.mitre.org/data/definitions/400.html) · [CWE-532](https://cwe.mitre.org/data/definitions/532.html) · [CWE-665](https://cwe.mitre.org/data/definitions/665.html) · [CWE-674](https://cwe.mitre.org/data/definitions/674.html) · [CWE-770](https://cwe.mitre.org/data/definitions/770.html) · [CWE-1325](https://cwe.mitre.org/data/definitions/1325.html)
- **Tags:** [Information disclosure](https://agentprime.io/advisories/tag/info-disclosure.md) · [Denial of service](https://agentprime.io/advisories/tag/dos.md) · [CWE-665](https://agentprime.io/advisories/tag/cwe-665.md) · [CWE-1325](https://agentprime.io/advisories/tag/cwe-1325.md)
- **Published:** 16 Apr 2026
- **Updated:** 16 Apr 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 16 Apr 2026, 22:50 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `Meridian.Mapping` (NuGet): affected `>=2.0.0, <2.1.1`; fixed in `2.1.1`
- `Meridian.Mediator` (NuGet): affected `>=2.0.0, <2.1.1`; fixed in `2.1.1`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** No score.

## Timeline

- 31 Oct 2026, 15:22 UTC: First seen by agentprime
- 31 Oct 2026, 15:22 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-f5v8-v6q3-q4h6)

## Sources

- [GitHub Advisory Database: GHSA-f5v8-v6q3-q4h6](https://github.com/advisories/GHSA-f5v8-v6q3-q4h6)
- [OSV: GHSA-f5v8-v6q3-q4h6](https://osv.dev/vulnerability/GHSA-f5v8-v6q3-q4h6)
- <https://github.com/UmutKorkmaz/meridian/security/advisories/GHSA-f5v8-v6q3-q4h6>
- <https://github.com/UmutKorkmaz/meridian>
- <https://github.com/UmutKorkmaz/meridian/blob/main/CHANGELOG.md#211---2026-04-16>
- <https://github.com/UmutKorkmaz/meridian/releases/tag/v2.1.1>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-f5v8-v6q3-q4h6>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-f5v8-v6q3-q4h6/>. Everything for agents: <https://agentprime.io/llms.txt>.
