# Apache Kylin vulnerable to Command injection by Useless configuration

Advisory record · `GHSA-f5q9-j9r2-34gq`

- **Identifiers:** `GHSA-f5q9-j9r2-34gq` · `CVE-2022-43396`
- **State:** Confirmed
- **Severity:** CVSS 8.8 High
- **Critical:** Yes: CVSS 7+ and EPSS
- **Weakness (CWE):** [CWE-77](https://cwe.mitre.org/data/definitions/77.html) · [CWE-184](https://cwe.mitre.org/data/definitions/184.html)
- **Tags:** [Command injection](https://agentprime.io/advisories/tag/command-injection.md) · [CWE-184](https://agentprime.io/advisories/tag/cwe-184.md)
- **Published:** 30 Dec 2022
- **Updated:** 11 Apr 2025
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 30 Dec 2022, 12:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 8.8 (7.0 or more) and EPSS 0.55 (0.1 or more): a high score and a real chance of exploitation in the next 30 days.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `org.apache.kylin:kylin` (Maven): affected `>=2.0.0, <4.0.3`; fixed in `4.0.3`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Apache Kylin versions 2.0.0 up to 4.0.3 (not including 4.0.3) are vulnerable to command injection. A user who can control the kylin.engine.spark-cmd configuration parameter can bypass the blacklist filter meant to block dangerous commands and run arbitrary commands. Upgrade to Apache Kylin 4.0.3, which is the listed fixed version.

Written 7 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.8 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.55, the 99th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:11 UTC: First seen by agentprime
- 31 Oct 2026, 15:11 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-f5q9-j9r2-34gq)

## Sources

- [GitHub Advisory Database: GHSA-f5q9-j9r2-34gq](https://github.com/advisories/GHSA-f5q9-j9r2-34gq)
- [OSV: GHSA-f5q9-j9r2-34gq](https://osv.dev/vulnerability/GHSA-f5q9-j9r2-34gq)
- <https://nvd.nist.gov/vuln/detail/CVE-2022-43396>
- <https://github.com/apache/kylin/pull/2011>
- <https://lists.apache.org/thread/ob2ks04zl5ms0r44cd74y1xdl1rzfd1r>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-f5q9-j9r2-34gq>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-f5q9-j9r2-34gq/>. Everything for agents: <https://agentprime.io/llms.txt>.
