# Apache Hadoop: Temporary File Local Information Disclosure

Advisory record · `GHSA-f5fw-25gw-5m92`

- **Identifiers:** `GHSA-f5fw-25gw-5m92` · `CVE-2024-23454`
- **State:** Confirmed
- **Severity:** CVSS 3.3 Low
- **Critical:** No
- **Weakness (CWE):** [CWE-269](https://cwe.mitre.org/data/definitions/269.html) · [CWE-378](https://cwe.mitre.org/data/definitions/378.html)
- **Tags:** [Privilege escalation](https://agentprime.io/advisories/tag/privilege-escalation.md) · [CWE-378](https://agentprime.io/advisories/tag/cwe-378.md)
- **Published:** 25 Sept 2024
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 25 Sept 2024, 09:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `org.apache.hadoop:hadoop-common` (Maven): affected `<3.4.0`; fixed in `3.4.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Versions of org.apache.hadoop:hadoop-common before 3.4.0 are affected. RunJar.run() does not set permissions on its temporary directory by default, so on unix-like systems other local users may be able to read sensitive files written there. Upgrade to hadoop-common 3.4.0 or later. The source gives few details on which data is written to that directory.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 3.3 Low, CVSS 3.1: `CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.0041, the 35th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:17 UTC: First seen by agentprime
- 31 Oct 2026, 14:17 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-f5fw-25gw-5m92)

## Sources

- [GitHub Advisory Database: GHSA-f5fw-25gw-5m92](https://github.com/advisories/GHSA-f5fw-25gw-5m92)
- [OSV: GHSA-f5fw-25gw-5m92](https://osv.dev/vulnerability/GHSA-f5fw-25gw-5m92)
- <https://nvd.nist.gov/vuln/detail/CVE-2024-23454>
- <https://github.com/apache/hadoop/commit/8c2836402fbb2f619f1fef4ef625a8542e853a64>
- <https://github.com/apache/hadoop>
- <https://issues.apache.org/jira/browse/HADOOP-19031>
- <https://lists.apache.org/thread/xlo7q8kn4tsjvx059r789oz19hzgfkfs>
- <https://security.netapp.com/advisory/ntap-20241101-0002>
- <http://www.openwall.com/lists/oss-security/2024/09/25/1>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-f5fw-25gw-5m92>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-f5fw-25gw-5m92/>. Everything for agents: <https://agentprime.io/llms.txt>.
