# OpenSearch vulnerable to Improper Authorization of Index Containing Sensitive Information

Advisory record · `GHSA-f4qr-f4xx-hjxw`

- **Identifiers:** `GHSA-f4qr-f4xx-hjxw` · `CVE-2022-35980`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-612](https://cwe.mitre.org/data/definitions/612.html)
- **Tags:** [CWE-612](https://agentprime.io/advisories/tag/cwe-612.md)
- **Published:** 12 Aug 2022
- **Updated:** 8 Nov 2023
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 12 Aug 2022, 17:31 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `org.opensearch.plugin:opensearch-security` (Maven): affected `>=2.0.0.0, <2.2.0.0`; fixed in `2.2.0.0`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.012, the 69th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 12 Aug 2022. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-f4qr-f4xx-hjxw](https://github.com/advisories/GHSA-f4qr-f4xx-hjxw)
- [OSV: GHSA-f4qr-f4xx-hjxw](https://osv.dev/vulnerability/GHSA-f4qr-f4xx-hjxw)
- <https://github.com/opensearch-project/security/security/advisories/GHSA-f4qr-f4xx-hjxw>
- <https://nvd.nist.gov/vuln/detail/CVE-2022-35980>
- <https://github.com/opensearch-project/security/pull/1999>
- <https://github.com/opensearch-project/security/commit/7eaaafec2939d7db23a02ffca9cc68e0343de246>
- <https://github.com/opensearch-project/security>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-f4qr-f4xx-hjxw>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-f4qr-f4xx-hjxw/>. Everything for agents: <https://agentprime.io/llms.txt>.
