# Possible CSRF attack at questionnaire templates preview

Advisory record · `GHSA-f3qm-vfc3-jg6v`

- **Identifiers:** `GHSA-f3qm-vfc3-jg6v` · `CVE-2023-47635`
- **State:** Confirmed
- **Severity:** CVSS 4.5 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-352](https://cwe.mitre.org/data/definitions/352.html) · [CWE-918](https://cwe.mitre.org/data/definitions/918.html)
- **Tags:** [Cross-site request forgery (CSRF)](https://agentprime.io/advisories/tag/csrf.md) · [Server-side request forgery (SSRF)](https://agentprime.io/advisories/tag/ssrf.md)
- **Published:** 20 Feb 2024
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 20 Feb 2024, 18:03 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `decidim-templates` (RubyGems): affected `>=0.23.0, <0.27.5`; fixed in `0.27.5`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 4.5 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:N/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0031, the 24th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:16 UTC: First seen by agentprime
- 31 Oct 2026, 15:16 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-f3qm-vfc3-jg6v)

## Sources

- [GitHub Advisory Database: GHSA-f3qm-vfc3-jg6v](https://github.com/advisories/GHSA-f3qm-vfc3-jg6v)
- [OSV: GHSA-f3qm-vfc3-jg6v](https://osv.dev/vulnerability/GHSA-f3qm-vfc3-jg6v)
- <https://github.com/decidim/decidim/security/advisories/GHSA-f3qm-vfc3-jg6v>
- <https://nvd.nist.gov/vuln/detail/CVE-2023-47635>
- <https://github.com/decidim/decidim/pull/11743>
- <https://github.com/decidim/decidim/pull/6247>
- <https://github.com/decidim/decidim/commit/5542227be66e3b6d7530f5b536069bce09376660>
- <https://github.com/decidim/decidim/commit/57a4b467787448307b5d9b01ce6e2c8502e121ac>
- <https://github.com/decidim/decidim>
- <https://github.com/decidim/decidim/blob/3187bdfd40ea1c57c2c12512b09a7fec0b2bed08/decidim-templates/app/controllers/decidim/templates/admin/questionnaire_templates_controller.rb#L11>
- <https://github.com/decidim/decidim/releases/tag/v0.27.5>
- <https://github.com/decidim/decidim/releases/tag/v0.28.0>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-f3qm-vfc3-jg6v>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-f3qm-vfc3-jg6v/>. Everything for agents: <https://agentprime.io/llms.txt>.
