# eslint-config-prettier, eslint-plugin-prettier, synckit, @pkgr/core, napi-postinstall have embedded malicious code

Advisory record · `GHSA-f29h-pxvx-f335`

- **Identifiers:** `GHSA-f29h-pxvx-f335` · `CVE-2025-54313`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** Yes: KEV
- **Weakness (CWE):** [CWE-506](https://cwe.mitre.org/data/definitions/506.html)
- **Tags:** [CWE-506](https://agentprime.io/advisories/tag/cwe-506.md)
- **Published:** 19 Jul 2025
- **Updated:** 3 Feb 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 19 Jul 2025, 18:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- In CISA’s KEV catalogue since 22 Jan 2026: it is known to be exploited.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `eslint-config-prettier` (npm): affected `>=8.10.1, <8.10.2 || >=9.1.1, <9.1.2 || >=10.1.6, <10.1.8`; fixed in `8.10.2`, `9.1.2`, `10.1.8`
- `eslint-plugin-prettier` (npm): affected `>=4.2.2, <4.2.4`; fixed in `4.2.4`
- `synckit` (npm): affected `>=0.11.9, <0.11.10`; fixed in `0.11.10`
- `@pkgr/core` (npm): affected `>=0.2.8, <0.2.9`; fixed in `0.2.9`
- `napi-postinstall` (npm): affected `>=0.3.1, <0.3.2`; fixed in `0.3.2`
- `got-fetch` (npm): affected `>=5.1.11, <6.0.0`; fixed in `6.0.0`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:H/A:N`, from CNA (mitre)

- **CISA KEV:** Listed since 22 Jan 2026: known to be exploited.
- **EPSS:** 0.051, the 92nd percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 19 Jul 2025. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-f29h-pxvx-f335](https://github.com/advisories/GHSA-f29h-pxvx-f335)
- [OSV: GHSA-f29h-pxvx-f335](https://osv.dev/vulnerability/GHSA-f29h-pxvx-f335)
- <https://nvd.nist.gov/vuln/detail/CVE-2025-54313>
- <https://github.com/prettier/eslint-config-prettier/issues/339>
- <https://github.com/prettier/eslint-config-prettier/commit/9b0b0a47ec28a7a83cf65e8436a8776910379385>
- <https://github.com/prettier/eslint-plugin-prettier/commit/ec39dd4400f10c52d10cd991c10fa8de51ceb854>
- <https://github.com/un-ts/napi-postinstall/commit/38b4e95cf554e2549b9e1e2c4ff6bff4da9a65f9>
- <https://github.com/un-ts/pkgr/commit/e1420c99e44d8a2ae949381f9fbe1af5ba9cb1dd>
- <https://github.com/un-ts/synckit/commit/8f2ee32d4f75736a1c8d7e1101190a71e48909e4>
- <https://www.stepsecurity.io/blog/supply-chain-security-alert-eslint-config-prettier-package-shows-signs-of-compromise>
- <https://www.npmjs.com/package/eslint-config-prettier?activeTab=versions>
- <https://www.endorlabs.com/learn/cve-2025-54313-eslint-config-prettier-compromise----high-severity-but-windows-only>
- <https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-54313>
- <https://www.bleepingcomputer.com/news/security/popular-npm-linter-packages-hijacked-via-phishing-to-drop-malware>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-f29h-pxvx-f335>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-f29h-pxvx-f335/>. Everything for agents: <https://agentprime.io/llms.txt>.
