# Pheditor: Authentication Bypass in Forced Password-Change Flow via Unverified Current Password

Advisory record · `GHSA-f25v-x6vr-962g`

- **Identifiers:** `GHSA-f25v-x6vr-962g` · `PKSA-jw7m-7sxt-c8zt`
- **State:** Confirmed
- **Severity:** CVSS 10.0 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-1392](https://cwe.mitre.org/data/definitions/1392.html)
- **Tags:** [CWE-1392](https://agentprime.io/advisories/tag/cwe-1392.md)
- **Published:** 24 Jul 2026
- **Updated:** 24 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 24 Jul 2026, 21:54 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 10.0: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `pheditor/pheditor` (Packagist): affected `<2.0.8`; fixed in `2.0.8`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Pheditor versions before 2.0.8 are affected. On instances where the default password has not been changed, the forced password-change flow does not check the submitted password against the current one, so an unauthenticated remote attacker can set a new admin password and obtain an authenticated session. Upgrade to Pheditor 2.0.8. The source lists no other workaround.

Written 3 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 10.0 Critical, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** No score.

## Timeline

- 31 Oct 2026, 14:24 UTC: First seen by agentprime
- 31 Oct 2026, 14:24 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-f25v-x6vr-962g)

## Sources

- [GitHub Advisory Database: GHSA-f25v-x6vr-962g](https://github.com/advisories/GHSA-f25v-x6vr-962g)
- [OSV: GHSA-f25v-x6vr-962g](https://osv.dev/vulnerability/GHSA-f25v-x6vr-962g)
- <https://github.com/pheditor/pheditor/security/advisories/GHSA-f25v-x6vr-962g>
- <https://github.com/pheditor/pheditor/commit/0978bcda644832b67357340e2f271e32d86fdf86>
- <https://github.com/pheditor/pheditor>
- <https://github.com/pheditor/pheditor/releases/tag/2.0.8>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-f25v-x6vr-962g>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-f25v-x6vr-962g/>. Everything for agents: <https://agentprime.io/llms.txt>.
