# MariaDB Connector/Node.js: Uncaught exception crashes the client during ed25519 authentication with zero-configuration TLS

Advisory record · `GHSA-cx2f-j9fh-8g68`

- **Identifiers:** `GHSA-cx2f-j9fh-8g68` · `BIT-mariadb-2026-107382` · `BIT-mariadb-min-2026-107382` · `BIT-mysql-client-2026-107382` · `CVE-2026-107382`
- **State:** Confirmed
- **Severity:** CVSS 5.9 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-248](https://cwe.mitre.org/data/definitions/248.html)
- **Tags:** [CWE-248](https://agentprime.io/advisories/tag/cwe-248.md)
- **Published:** 8 Oct 2026
- **Updated:** 16 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 8 Oct 2026, 19:42 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `mariadb` (npm): affected `>=3.3.0, <3.5.4`; fixed in `3.5.4`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The mariadb npm package, versions 3.3.0 up to but not including 3.5.4, crashes its Node.js client during ed25519 authentication over zero-configuration TLS without a supplied CA. An attacker who can intercept the connection, or a compromised server, can trigger an uncaught exception that terminates the client process. Upgrade to mariadb 3.5.4 or later; the 3.3.x and 3.4.x branches are not patched.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.9 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0024, the 14th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 13:33 UTC: First seen by agentprime
- 31 Oct 2026, 13:33 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-cx2f-j9fh-8g68)

## Sources

- [GitHub Advisory Database: GHSA-cx2f-j9fh-8g68](https://github.com/advisories/GHSA-cx2f-j9fh-8g68)
- [OSV: GHSA-cx2f-j9fh-8g68](https://osv.dev/vulnerability/GHSA-cx2f-j9fh-8g68)
- <https://github.com/mariadb-corporation/mariadb-connector-nodejs/security/advisories/GHSA-cx2f-j9fh-8g68>
- <https://github.com/mariadb-corporation/mariadb-connector-nodejs/commit/784ca3d757194a05f202d84b0c762321e76a7915>
- <https://github.com/mariadb-corporation/mariadb-connector-nodejs>
- <https://github.com/mariadb-corporation/mariadb-connector-nodejs/releases/tag/3.5.4>
- <https://jira.mariadb.org/browse/CONJS-356>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-cx2f-j9fh-8g68>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-cx2f-j9fh-8g68/>. Everything for agents: <https://agentprime.io/llms.txt>.
