# tlslite-ng off-by-one error on mac checking

Advisory record · `GHSA-cwh5-3cw7-4286`

- **Identifiers:** `GHSA-cwh5-3cw7-4286` · `CVE-2018-1000159` · `PYSEC-2018-31`
- **State:** Confirmed
- **Severity:** CVSS 5.9 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-354](https://cwe.mitre.org/data/definitions/354.html)
- **Tags:** [CWE-354](https://agentprime.io/advisories/tag/cwe-354.md)
- **Published:** 12 Jul 2018
- **Updated:** 24 Nov 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 12 Jul 2018, 20:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `tlslite-ng` (PyPI): affected `<0.7.4`; fixed in `0.7.4`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.9 Medium, CVSS 3.0: `CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.0077, the 55th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 12 Jul 2018. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-cwh5-3cw7-4286](https://github.com/advisories/GHSA-cwh5-3cw7-4286)
- [OSV: GHSA-cwh5-3cw7-4286](https://osv.dev/vulnerability/GHSA-cwh5-3cw7-4286)
- <https://nvd.nist.gov/vuln/detail/CVE-2018-1000159>
- <https://github.com/tlsfuzzer/tlslite-ng/pull/234/commits/3674815d1b0f7484454995e2737a352e0a6a93d8>
- <https://github.com/tomato42/tlslite-ng/pull/234>
- <https://github.com/tlsfuzzer/tlslite-ng/commit/d7b288316bca7bcdd082e6ccff5491e241305233>
- <https://github.com/pypa/advisory-database/tree/main/vulns/tlslite-ng/PYSEC-2018-31.yaml>
- <https://github.com/tomato42/tlslite-ng>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-cwh5-3cw7-4286>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-cwh5-3cw7-4286/>. Everything for agents: <https://agentprime.io/llms.txt>.
