# omniauth-saml vulnerable to Improper Verification of Cryptographic Signature

Advisory record · `GHSA-cvp8-5r8g-fhvq`

- **Identifiers:** `GHSA-cvp8-5r8g-fhvq`
- **State:** Confirmed
- **Severity:** CVSS 10.0 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-347](https://cwe.mitre.org/data/definitions/347.html)
- **Tags:** [Weak cryptography or TLS](https://agentprime.io/advisories/tag/weak-crypto.md)
- **Published:** 11 Sept 2024
- **Updated:** 7 Aug 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 11 Sept 2024, 21:08 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 10.0: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `omniauth-saml` (RubyGems): affected `>=2.0.0, <2.1.2 || <1.10.5 || >=2.2.0, <2.2.1`; fixed in `2.1.2`, `1.10.5`, `2.2.1`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 10.0 Critical, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** No score.

## Timeline

- 31 Oct 2026, 15:16 UTC: First seen by agentprime
- 31 Oct 2026, 15:16 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-cvp8-5r8g-fhvq)

## Sources

- [GitHub Advisory Database: GHSA-cvp8-5r8g-fhvq](https://github.com/advisories/GHSA-cvp8-5r8g-fhvq)
- [OSV: GHSA-cvp8-5r8g-fhvq](https://osv.dev/vulnerability/GHSA-cvp8-5r8g-fhvq)
- <https://github.com/SAML-Toolkits/ruby-saml/security/advisories/GHSA-jw9c-mfg7-9rx2>
- <https://github.com/omniauth/omniauth-saml/security/advisories/GHSA-cvp8-5r8g-fhvq>
- <https://github.com/omniauth/omniauth-saml/commit/4274e9d57e65f2dcaae4aa3b2accf831494f2ddd>
- <https://github.com/omniauth/omniauth-saml/commit/6c681fd082ab3daf271821897a40ab3417382e29>
- <https://github.com/omniauth/omniauth-saml>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/omniauth-saml/GHSA-cvp8-5r8g-fhvq.yml>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-cvp8-5r8g-fhvq>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-cvp8-5r8g-fhvq/>. Everything for agents: <https://agentprime.io/llms.txt>.
