# Improper Removal of Sensitive Information Before Storage or Transfer in irrd

Advisory record · `GHSA-cqxx-66wh-8pjw`

- **Identifiers:** `GHSA-cqxx-66wh-8pjw` · `CVE-2022-24798` · `PYSEC-2022-178`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-212](https://cwe.mitre.org/data/definitions/212.html)
- **Tags:** [CWE-212](https://agentprime.io/advisories/tag/cwe-212.md)
- **Published:** 1 Apr 2022
- **Updated:** 24 Sept 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 1 Apr 2022, 13:59 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `irrd` (PyPI): affected `>=4.2.0, <4.2.3`; fixed in `4.2.3`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.014, the 72nd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 1 Apr 2022. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-cqxx-66wh-8pjw](https://github.com/advisories/GHSA-cqxx-66wh-8pjw)
- [OSV: GHSA-cqxx-66wh-8pjw](https://osv.dev/vulnerability/GHSA-cqxx-66wh-8pjw)
- <https://github.com/irrdnet/irrd/security/advisories/GHSA-cqxx-66wh-8pjw>
- <https://nvd.nist.gov/vuln/detail/CVE-2022-24798>
- <https://github.com/irrdnet/irrd/commit/0e41bae8d3d27316381a2fc7b466597230e35ec6>
- <https://github.com/irrdnet/irrd/commit/fdffaf8dd71713f06e99dff417e6aa1e6fa84b70>
- <https://github.com/irrdnet/irrd>
- <https://github.com/pypa/advisory-database/tree/main/vulns/irrd/PYSEC-2022-178.yaml>
- <https://irrd.readthedocs.io/en/stable/releases/4.2.3>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-cqxx-66wh-8pjw>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-cqxx-66wh-8pjw/>. Everything for agents: <https://agentprime.io/llms.txt>.
