# Ansible apt_key module does not properly verify key fingerprint

Advisory record · `GHSA-cmwx-9m2h-x7v4`

- **Identifiers:** `GHSA-cmwx-9m2h-x7v4` · `CVE-2016-8614` · `PYSEC-2018-37`
- **State:** Confirmed
- **Severity:** CVSS 6.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-358](https://cwe.mitre.org/data/definitions/358.html)
- **Tags:** [CWE-358](https://agentprime.io/advisories/tag/cwe-358.md)
- **Published:** 10 Oct 2018
- **Updated:** 3 Sept 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 10 Oct 2018, 17:23 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `ansible` (PyPI): affected `<2.2.0.0`; fixed in `2.2.0.0`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.3 Medium, CVSS 3.0: `CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L`, from CNA (redhat)

- **CISA KEV:** Not listed.
- **EPSS:** 0.025, the 84th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 10 Oct 2018. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-cmwx-9m2h-x7v4](https://github.com/advisories/GHSA-cmwx-9m2h-x7v4)
- [OSV: GHSA-cmwx-9m2h-x7v4](https://osv.dev/vulnerability/GHSA-cmwx-9m2h-x7v4)
- <https://nvd.nist.gov/vuln/detail/CVE-2016-8614>
- <https://github.com/ansible/ansible-modules-core/issues/5237>
- <https://github.com/ansible/ansible-modules-core/pull/5353>
- <https://github.com/ansible/ansible-modules-core/pull/5357>
- <https://github.com/ansible/ansible-modules-core/commit/1182d1f0b76d56f3667e27987a10b9ec8f03357d>
- <https://github.com/ansible/ansible-modules-core/commit/66d47c8149d84e52f64b7c4d1f340d45dca94d9c>
- <https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2016-8614>
- <https://github.com/advisories/GHSA-cmwx-9m2h-x7v4>
- <https://github.com/ansible/ansible>
- <https://github.com/pypa/advisory-database/tree/main/vulns/ansible/PYSEC-2018-37.yaml>
- <https://web.archive.org/web/20200227214450/https://www.securityfocus.com/bid/94108>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-cmwx-9m2h-x7v4>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-cmwx-9m2h-x7v4/>. Everything for agents: <https://agentprime.io/llms.txt>.
