# Netty's Default QUIC token handler accepts any client-supplied token

Advisory record · `GHSA-cmm3-54f8-px4j`

- **Identifiers:** `GHSA-cmm3-54f8-px4j` · `CVE-2026-44894`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-346](https://cwe.mitre.org/data/definitions/346.html) · [CWE-940](https://cwe.mitre.org/data/definitions/940.html)
- **Tags:** [CWE-346](https://agentprime.io/advisories/tag/cwe-346.md) · [CWE-940](https://agentprime.io/advisories/tag/cwe-940.md)
- **Published:** 8 Jun 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 8 Jun 2026, 22:59 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `io.netty:netty-codec-classes-quic` (Maven): affected `>=4.2.0.Final, <4.2.15.Final`; fixed in `4.2.15.Final`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Netty's netty-codec-classes-quic package, versions 4.2.0.Final up to but not including 4.2.15.Final, is affected. When the application does not set a QUIC token handler, the default handler accepts any client-supplied token as valid. A remote attacker who can send packets with a spoofed source address can then make the server skip address validation and send full-size handshake responses to the victim without the usual amplification limit. Upgrade to 4.2.15.Final or later.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0014, the 3rd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:16 UTC: First seen by agentprime
- 31 Oct 2026, 14:16 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-cmm3-54f8-px4j)

## Sources

- [GitHub Advisory Database: GHSA-cmm3-54f8-px4j](https://github.com/advisories/GHSA-cmm3-54f8-px4j)
- [OSV: GHSA-cmm3-54f8-px4j](https://osv.dev/vulnerability/GHSA-cmm3-54f8-px4j)
- <https://github.com/netty/netty/security/advisories/GHSA-cmm3-54f8-px4j>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-44894>
- <https://github.com/netty/netty>
- <https://github.com/netty/netty/releases/tag/netty-4.2.15.Final>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-cmm3-54f8-px4j>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-cmm3-54f8-px4j/>. Everything for agents: <https://agentprime.io/llms.txt>.
