# Incomplete validation in \`SparseAdd\`

Advisory record · `GHSA-cjc7-49v2-jp64`

- **Identifiers:** `GHSA-cjc7-49v2-jp64` · `BIT-tensorflow-2021-29609` · `CVE-2021-29609` · `PYSEC-2021-246` · `PYSEC-2021-537` · `PYSEC-2021-735`
- **State:** Confirmed
- **Severity:** CVSS 5.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-665](https://cwe.mitre.org/data/definitions/665.html) · [CWE-787](https://cwe.mitre.org/data/definitions/787.html)
- **Tags:** [Memory corruption](https://agentprime.io/advisories/tag/memory-corruption.md) · [CWE-665](https://agentprime.io/advisories/tag/cwe-665.md)
- **Published:** 21 May 2021
- **Updated:** 8 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 21 May 2021, 14:28 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `tensorflow` (PyPI): affected `<2.1.4 || >=2.2.0, <2.2.3 || >=2.3.0, <2.3.3 || >=2.4.0, <2.4.2`; fixed in `2.1.4`, `2.2.3`, `2.3.3`, `2.4.2`
- `tensorflow-cpu` (PyPI): affected `<2.1.4 || >=2.2.0, <2.2.3 || >=2.3.0, <2.3.3 || >=2.4.0, <2.4.2`; fixed in `2.1.4`, `2.2.3`, `2.3.3`, `2.4.2`
- `tensorflow-gpu` (PyPI): affected `<2.1.4 || >=2.2.0, <2.2.3 || >=2.3.0, <2.3.3 || >=2.4.0, <2.4.2`; fixed in `2.1.4`, `2.2.3`, `2.3.3`, `2.4.2`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.3 Medium, CVSS 3.1: `CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0023, the 14th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 21 May 2021. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-cjc7-49v2-jp64](https://github.com/advisories/GHSA-cjc7-49v2-jp64)
- [OSV: GHSA-cjc7-49v2-jp64](https://osv.dev/vulnerability/GHSA-cjc7-49v2-jp64)
- <https://github.com/tensorflow/tensorflow/security/advisories/GHSA-cjc7-49v2-jp64>
- <https://nvd.nist.gov/vuln/detail/CVE-2021-29609>
- <https://github.com/tensorflow/tensorflow/commit/41727ff06111117bdf86b37db198217fd7a143cc>
- <https://github.com/tensorflow/tensorflow/commit/6fd02f44810754ae7481838b6a67c5df7f909ca3>
- <https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-537.yaml>
- <https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-735.yaml>
- <https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-246.yaml>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-cjc7-49v2-jp64>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-cjc7-49v2-jp64/>. Everything for agents: <https://agentprime.io/llms.txt>.
