# Black: GitHub Action installs unvalidated required-version from pyproject.toml

Advisory record · `GHSA-cg8m-r9f2-5wm2`

- **Identifiers:** `GHSA-cg8m-r9f2-5wm2` · `CVE-2026-114134`
- **State:** Confirmed
- **Severity:** CVSS 8.7 High
- **Critical:** No
- **Weakness (CWE):** [CWE-829](https://cwe.mitre.org/data/definitions/829.html)
- **Tags:** [CWE-829](https://agentprime.io/advisories/tag/cwe-829.md)
- **Published:** 22 Oct 2026
- **Updated:** 22 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 22 Oct 2026, 16:18 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `black` (PyPI): affected `<26.10.1`; fixed in `26.10.1`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Black versions before 26.10.1 have a vulnerability in the GitHub Action bundled with Black when \`use_pyproject\` is set to True: the version read from \`tool.black.required-version\` in pyproject.toml is installed without validation. An attacker who can submit a pull request to the victim's repository could point this value at a malicious source and run code in the context of the repository. Upgrade to Black 26.10.1 or later.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.7 High, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** No score.

## Timeline

- 31 Oct 2026, 14:08 UTC: First seen by agentprime
- 31 Oct 2026, 14:08 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-cg8m-r9f2-5wm2)
- 5 Nov 2026, 20:22 UTC: [Confirmed by the CVE List](https://www.cve.org/CVERecord?id=CVE-2026-114134)
- 5 Nov 2026, 21:18 UTC: [Confirmed by NVD](https://nvd.nist.gov/vuln/detail/CVE-2026-114134)

## Sources

- [GitHub Advisory Database: GHSA-cg8m-r9f2-5wm2](https://github.com/advisories/GHSA-cg8m-r9f2-5wm2)
- [OSV: GHSA-cg8m-r9f2-5wm2](https://osv.dev/vulnerability/GHSA-cg8m-r9f2-5wm2)
- <https://github.com/psf/black/security/advisories/GHSA-cg8m-r9f2-5wm2>
- <https://github.com/psf/black/pull/5510>
- <https://github.com/psf/black/commit/ac1f71563aeccf73cf13ece00f231d9d6c66a514>
- <https://github.com/psf/black>
- <https://github.com/psf/black/releases/tag/26.10.1>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-cg8m-r9f2-5wm2>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-cg8m-r9f2-5wm2/>. Everything for agents: <https://agentprime.io/llms.txt>.
